Home > VLAN Trunking

VLAN Trunking

May 3rd, 2015 in SWITCH 300-115 Go to comments

Question 1

Explanation

These errors are generated because the native VLAN is not matched on the two switches (the native VLAN on SW-1 is not the default native VLAN 1 while the native VLAN on the other side is VLAN 1). The errors indicate that spanning tree has detected mismatched native VLANs and has shut down VLAN 1 on the trunk.

We should verify that the configurations of the native VLAN ID is consistent on the interfaces on each end of the IEEE 802.1Q trunk connection. When the configurations are consistent, spanning tree automatically unblocks the interfaces.

Question 2

Explanation

In 802.1Q, the trunking device inserts a 4-byte tag into the original frame and recomputes the frame check sequence (FCS) before the device sends the frame over the trunk link. At the receiving end, the tag is removed and the frame is forwarded to the assigned VLAN. 802.1Q does not tag frames on the native VLAN. It tags all other frames that are transmitted and received on the trunk.

Reference: http://www.cisco.com/c/en/us/support/docs/lan-switching/8021q/17056-741-4.html

Question 3

Explanation

802.1Q is a industry standards based implementation of carrying traffic for multiple VLANs on a single trunking interface between two Ethernet switches. 802.1Q is for Ethernet networks only.

Question 4

Explanation

We can use the “switchport trunk allowed vlan ” to specify which VLANs are allowed to go through. Other VLANs will be dropped.

Question 5

Explanation

Manually configure trunking with the “switchport mode trunk” command and manually configure access interfaces with the “switchport mode access” prevent auto trunking on that interface.

Disable DTP with the “switchport nonegotiate” so that DTP messages are not advertised out of the interface is also a good way to prevent auto trunking.

Question 6

Explanation

There are two protocols that can be used for trunking: Inter-Switch Link (ISL) and 802.1Q. We can choose which protocol to run by the “switchport trunk encapsulation “. After that we can configure trunking mode with the “switchport mode trunk” command.

In fact this question is not clear and may cause confusion because Dynamic Trunking Protocol (DTP) is the protocol that can automatically negotiate for trunking.

Note: The DTP options can be dynamic auto, dynamic desirable, and trunk.

Question 7

Explanation

By default all VLANs are allowed to go through a trunk but if we apply the “switchport trunk allowed vlan ” then only these VLANs are allowed to go through, other VLANs are dropped so be careful when limiting VLANs on the trunks with this command.

Question 8

Explanation

We can use the “switchport trunk allowed vlan ” to specify which VLANs are allowed to go through. Other VLANs will be dropped.

Question 9

Explanation

First we will explain these two commands:

switchport access vlan 10
switchport mode trunk

The first command is used for an access port whist the second is used for a trunk so why are they here at the same time? In fact this interface was set as a trunk. The “switchport access vlan 10” is still there but it does not affect the operational mode of the port -> Gi1/0/1 is a trunk port so it will not appear in the “show vlan” command.

The “switchport voice vlan 11” command here only tries to confuse you. But it does have an effect on the port: Cisco uses CDP to specify a Cisco IP Phone and will automatically place that traffic into the voice VLAN. For example if we configure like this:

interface fa0/0
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 11

Then the voice traffic from a Cisco IP Phone will be placed into VLAN 11.

Cisco_IP_Phone_data_voice_VLANs.jpg

Note: In the above configuration, the data and voice use the same interface fa0/0 so it should be configured as a trunk link.

(Reference: http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_example09186a0080722cdb.shtml)

Question 10

Explanation

VLAN 1 is always used for CDP, VTP, PAgP traffic (except DTP uses native VLAN) even if VLAN 1 is not the native VLAN. If VLAN 1 is not the native VLAN then CDP, VTP, PAgP traffic will be tagged on the trunk.

In this question, after changing the default native VLAN to 999 while keeping the standard configuration on the other end, we cause a “native VLAN mismatched” error. Besides, CDP, VTP traffic is tagged on the local switch (as VLAN 1 is no longer the native VLAN) so the other end cannot understand them -> CDP, VTP traffic is dropped.

Comments
  1. asker
    April 13th, 2015

    hi, some people say they tried it on a actual switch and the answer is B. can those people who possess actual switches try to put another switch connected to corresponding interface (Gi1/0/1) and set it as a trunk? if you do so i believe answer would again be A but i am not sure. Thanks!

  2. Bigornado
    April 14th, 2015

    So, first i tried in real switch 3750 and see the answer B correct! After that im create a trunk link between two switch’s same model and see A correct, you can try do it free here http://labswitch.blogspot.com.br

    Please post the result, i think the question a little bit confuse but a believe trunk between both switch…

    Thanks!

  3. Chaks
    April 17th, 2015

    I tried with packet tracer on both the 2950 and 3560 and seems the answer is D.

  4. DP
    April 18th, 2015

    Q9. Answer is A. It is clearly explained by certprepare.

  5. Wilbur
    April 23rd, 2015

    Q9:
    Answer A is when a device is connected and the interface is up.
    Answer B and C are wrong because the switchport is no member of that Vlan.
    Answer D is only when no device is connected, when the interface is down, it doesn’t show in the Vlan list.
    The question is what do you expect, of course you configure a port when you want to use it so Answer A is correct, just connect a device in Packer tracer p.e. and you’ll see ;)

  6. Wally
    April 27th, 2015

    I tried with GNS3 connecting an active VPCS (virtual PC) to interface fa 1/0, it gave me answer A. Which makes sense, the trunk carries data and voice vlans, qos and cos will be needed on voice vlan tho.

  7. XJIM
    May 6th, 2015

    Tested on real 3560v2 48PSS Answer is clearly >>B<<:

    test#sh run int
    *Mar 1 00:02:49.265: %SYS-5-CONFIG_I: Configured from console by console Fa0/1
    Building configuration…

    Current configuration : 171 bytes
    !
    interface FastEthernet0/1
    switchport access vlan 10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 11
    spanning-tree portfast
    end

    test#sh vlan

    VLAN Name Status Ports
    —- ——————————– ——— ——————————-
    1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
    Fa0/6, Fa0/7, Fa0/8, Fa0/9
    Fa0/10, Fa0/11, Fa0/12, Fa0/13
    Fa0/14, Fa0/15, Fa0/16, Fa0/17
    Fa0/18, Fa0/19, Fa0/20, Fa0/21
    Fa0/22, Fa0/23, Fa0/24, Fa0/25
    Fa0/26, Fa0/27, Fa0/28, Fa0/29
    Fa0/30, Fa0/31, Fa0/32, Fa0/33
    Fa0/34, Fa0/35, Fa0/36, Fa0/37
    Fa0/38, Fa0/39, Fa0/40, Fa0/41
    Fa0/42, Fa0/43, Fa0/44, Fa0/45
    Fa0/46, Fa0/47, Fa0/48, Gi0/1
    Gi0/2, Gi0/3, Gi0/4
    10 VLAN0010 active Fa0/1
    11 VLAN0011 active Fa0/1
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

  8. jammer
    May 23rd, 2015

    Question 9: Tested in Packet Tracer:
    – Answer is A when the the port is up/up with another switch (trunking)
    – Answer is D when I shut down the other switches trunk port (first switch’s interface reverts to access mode).
    Makes me think answer is “A” as the question is given.

  9. DimS
    May 25th, 2015

    Q5: Why answer C is incorrect? Disabling DTP ( switchport nonegotiate ) won’t protect you if user connected a switch that have ports in dynamic desirable mode. It will establish trunk anyway. But BPDUGuard have to put this port in err-disable mode, shutting him down and protect you.

  10. Tang Bo Hu
    May 26th, 2015

    Regarding Question 9, I verified on a Cisco switch with C3560 that answer A was correct.

    VLAN Name Status Ports
    —- ——————————– ——— ——————————-
    1 default active Fa0/1, Fa0/2, Fa0/4, Fa0/5
    Fa0/6, Fa0/7, Fa0/8, Fa0/9
    Fa0/10, Fa0/11, Fa0/12, Fa0/13
    Fa0/14, Fa0/15, Fa0/16, Fa0/17
    Fa0/18, Fa0/19, Fa0/20, Fa0/21
    Fa0/22, Fa0/23, Fa0/24, Gi0/1
    Gi0/2
    10 VLAN0010 active
    11 VLAN0011 active
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

  11. DimS
    May 29th, 2015

    @DimS: DTP, STP, VTP… Who cares?.. :)))
    I’m sorry?Q5 right answers are: A, B.

  12. JBeam
    June 20th, 2015

    Q8 should be B, here’s a reference from Ciscopress showing once data and voice vlans are assigned to a port, you’ll see both with show vlan command.
    http://www.ciscopress.com/articles/article.asp?p=1745631&seqNum=3

  13. JBeam
    June 20th, 2015

    Now I’m second guessing that because their example is for an access port.

  14. Anonymous
    July 8th, 2015

    JBeam, the article says: ” Also, keep in mind that port Fa0/1 does not appear in the Example 3-2 output because it is configured as a trunk port ”

    So the correct answer is A

  15. hyperoxyd
    July 13th, 2015

    was also tempted to try in GNS3 – just connected two switches configured both fa interfaces the same (no spanning tree) and if I disconnected the cable then the port appeared in the data vlan when connected them up again port wasn’t showing anywhere (trunk)

    so I’m saying A is correct too

  16. GZR
    July 24th, 2015

    Question 9: Tested this with PC connected to phone conneted to switch and get answer A. Disconnect the phone from the switchport and the answer is B. So the answer will be A or B depending on whether you believe the question implies devices are connected to the switchport.

    C or D will definitely not be a correct answer. PacketTracer is good but it is not a perfect replica of IOS behaviour and so the observations using this tool can not always be trusted.

  17. siva
    August 6th, 2015

    Hi I can not see the question ,can see the explanation only ,,…….can any one help me.

  18. Htoon
    August 9th, 2015

    The questions are missing and only answers and explanations,

    Those who take care of the sites, please remedy it asap

    thanks

  19. anon
    August 27th, 2015

    Q9 – tested config of a real 2960X.
    The result showed B as the correct answer (I had no devices connected). I’m going with B if it comes up in the exam.

    People asking where the questions are….they were removed due to copy right. Search the share your experience section for a link to the questions.

  20. certprepare
    August 29th, 2015

    Because of copyrighted issues, certprepare had to remove all questions and answers. You can download them at http://www.mediafire.com/view/9mq20kx0mgam6k7/SWITCH_July_2015.pdf

  21. reezinmohamed
    September 1st, 2015

    Q.9 Answer should be A, bcz when we connect device with this configuration it will work like TRUNK PORT so answer should be A… I checked this with packet tracer

  22. Turtlek
    September 3rd, 2015

    Q9 = A
    Tested on 2950 live switch. Matched B when disconnected, A when connected to PC
    Tested in Packet Tracer, 3560 IOS 12.2 – matched D when disconnected, A when connected to PC.

  23. saif
    September 10th, 2015

    Thank u Certprepre

  24. Cornel
    September 22nd, 2015

    For Q1
    Complete messages:

    3w2d: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on GigabitEthernet1/2 VLAN2013.
    3w2d: %SPANTREE-2-BLOCK_PVID_PEER: Blocking GigabitEthernet1/2 on VLAN0001. Inconsistent peer vlan.
    3w2d: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/2 on VLAN2013. Inconsistent local vlan.
    3560#
    3w2d: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/2 (2013), with 3560_1.3560_1.com GigabitEthernet1/2 (1).
    3560# Next, after rematch native vlans.
    3w2d: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking GigabitEthernet1/2 on VLAN0001. Port consistency restored.
    3w2d: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking GigabitEthernet1/2 on VLAN2013. Port consistency restored.

  25. visaya
    September 23rd, 2015

    Q9 = A
    Tested with 3750 and Cisco 7940 Phone. The interface port becomes a Trunk. Remember a Trunk.
    But if you unplugged the Cisco 7940 phone, Q9 = B with interface port is down/down.
    Best answer for Q9 = A.

  26. Tpoxa
    October 27th, 2015

    @certprepare
    Q9: tested on a real
    Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(50)SE5, RELEASE SOFTWARE (fc1)

    #sh run inter fa 0/18
    Building configuration…

    Current configuration : 164 bytes
    !
    interface FastEthernet0/18
    description CCNP_Switch_test
    switchport access vlan 88
    switchport mode trunk
    switchport voice vlan 89
    spanning-tree portfast
    end

    #sh vlan | i 18
    88 VLAN0088 active Fa0/18
    89 VLAN0089 active Fa0/18

    Agree to @XJIM, here correct is “B”.

    @certprepare: do you believe the correct answer is still “A”?

  27. CCNPtaker
    November 3rd, 2015

    lol guys dont try this on packet tracer, try it on real switch. packet tracer in CCNP is lame

  28. Ray
    November 11th, 2015

    @ Tpoxa
    Answer is A. Tested on real 3750 and answer is A. When port is connected the answer is A.

    SW1#sh run int f1/0/1
    Building configuration…

    Current configuration : 192 bytes
    !
    interface FastEthernet1/0/1
    description Test
    switchport access vlan 88
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 89
    spanning-tree portfast
    end

    *************
    PORT CONNECTED
    SW1#sh vlan

    VLAN Name Status Ports
    —- ——————————– ——— ——————————-

    88 VLAN0088 active
    89 VLAN0089 active

    ****************
    PORT DISCONNECTED:

    SW1#sh vlan

    VLAN Name Status Ports
    —- ——————————– ——— ——————————-

    88 VLAN0088 active Fa1/0/1
    89 VLAN0089 active Fa1/0/1

  29. Question 5
    November 15th, 2015

    Question 5

    For security reasons, the IT manager has prohibited users from dynamically establishing trunks with their associated upstream switch. Which two actions can prevent interface trunking? (Choose two)

    A. Configure trunk and access interfaces manually.
    B. Disable DTP on a per interface basis.
    C. Apply BPDU guard and BPDU filter.
    D. Enable switchport block on access ports.

    I did quiz 7 and the correct answer was the same as you have put above A and B

    But when I did quiz 6 , the answers were A ( Correct ) B ( incorrect ) c ( Correct ).

    Can you please correct the quiz so it is not marking incorrectly.

    Thank is advance.

    Doing a sterling job guys.

  30. Tpoxa
    November 22nd, 2015

    @Ray
    Hmmm, thanks, man. Will shortly reproduce this with connected ports. My were not connected, so that’s why I did see my Fa 0/18 within both vlans.

  31. CCNPtaker
    December 13th, 2015

    guys please stop using PACKET TRACER. it’s only for CCNA, it’s behavior for CCNP cannot be trusted. so listen to the ones with the real switch!

  32. Raddy
    March 8th, 2016

    A nice artcile for VTP in packet tracer is below:
    http://ipcisco.com/vtp-configuration-with-packet-tracer/
    enjoy ;)

  33. barkoulis
    March 15th, 2016

    @certpepare . An answer to all the guys above about Q9 would be nice!!!

  34. CCNP
    March 21st, 2016

    Q9) On any Cisco switch, if the Trunk is down, it will show up in VLAN 1 by default. So if you have another VL configured, it will show up in that VLAN.

    However, I have a bigger issue with the explanation: “In the above configuration, the data and voice use the same interface fa0/0 so it should be configured as a trunk link.” => VOIP ports are ALWAYS configured as ACCESS PORTS. Per the link you shared right after the quote above:

    “When you connect an IP phone to a switch using a trunk link, it can cause high CPU utilization in the switches. As all the VLANs for a particular interface are trunked to the phone, it increases the number of STP instances the switch has to manage. This increases the CPU utilization. Trunking also causes unnecessary broadcast / multicast / unknown unicast traffic to hit the phone link. / In order to avoid this, remove the trunk configuration and keep the voice and access VLAN configured along with Quality of Service (QoS). Technically, it is still a trunk, but it is called a Multi-VLAN Access Port (MVAP).”

    Furthermore, as soon as you enter the “switchport voice vlan” command, it will add the “span portfast” command – NEVER a good idea for TRUNK ports.

  35. Nishant
    March 24th, 2016

    I did not find question . Where can we get the questions from ?

  36. Boban
    May 20th, 2016

    Q9: A is correct.

    When you configure the interface with these commands
    switchport access vlan 10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 11
    spanning-tree portfast

    and if the interface is DOWN , then B is correct. But when the interface is UP, A is correct.
    Tested on real 3560.

  37. skymax
    July 12th, 2016

    Hi,

    Recently, I personally passed CCNP Route 300-101,SWITCH 300-115,TSHOOT 300-135 exams with full marks.
    I have purchased latest Premium vce dumps file that are 100% valid and I’m giving at nominal sharing cost.wanninayakegcb@gmail_com

  38. sii
    August 23rd, 2016

    hi all
    can any one send the vce player sopprusbarbosa at gmail . com

  39. cg
    October 21st, 2016

    Q4 Trunk
    indeed switchport trunk allowed vlan is the command,
    but this is referred as manual pruning.
    So if the technique is asked, what’s the real answer?

  40. M.I.
    October 23rd, 2016

    Q4:

    By default, a trunk port sends traffic to and receives traffic from all VLANs. All VLAN IDs, 1 to 4094, are allowed on each trunk. However, you can remove VLANs from the allowed list, preventing traffic from those VLANs from passing over the trunk. To restrict the traffic a trunk carries, use the “switchport trunk allowed vlan remove vlan-list” interface configuration command to remove specific VLANs from the allowed list.

    So I think the correct is C

  41. Kure
    October 30th, 2016

    Q 9,
    the correct answer is B,
    try on catalyst 3560,
    with ip phone plugged in port, and ip phone unplugged,
    show vlan display the physical port that belong to vlans

  42. Spencer Moore
    November 11th, 2016

    Passed the exam and can attest that the study materials from https://www.examsbuzz.com/100-105-exam.html as mentioned above is valid :D It contains all the new questions from the update in November. Would recommend his study materials. Cheers!

  43. Meh
    November 14th, 2016

    Grade4sure is the right choice to provide you Cisco 300-115 Dumps. These dumps have 300-115 exam questions answers in both PDF and Online Test Engine formats. All question answers are written to the highest standards of technical accuracy by our professionals.
    http://www.grades4sure.com/300-115-exam-questions.html

  44. The Grinch
    December 12th, 2016

    Finally passed the Route! Was a long journey… As I got caught in the update. However came across the ebay dump mentioned by others and passed the exam yesterday. The materials are still vailid. Like how he has packet tracer available for 3 of the simulations. It was good practice. No new questions.

    The link below is the ebay matierlas I have utilized, if you would like to use as well:

    http://www.ebay.com/itm/-/322352636952?

    Cheers Guys and Happy Holidays!

  45. paul
    February 13th, 2017

    Hi! About question 10:

    #show run

    #int fa0/1
    #switchport trunk encap dot1q
    #switchport trunk allowed vlan 1-90,100-199,200-900,1000-4000
    #switchport mode trunk

    A network engineer changes the default native VLAN to VLAN 999. After applying the settings on the uplinks to the core switches, the switch control traffic, such as CDP and VTP, is no longer working. The standard configuration is used for each uplink. What is wrong with the configuration?

    A. The interface is administratively down.
    B. The encapsulation type is incorrect.
    C. The switchport mode trunk command should be first in the output.
    D. The native VLAN is not present on the trunk.
    E. The control traffic must be manually enabled on the new native VLAN.

    Answer D or E ?
    I think D . Please confirm me?
    Thanks

  46. Simao..
    February 24th, 2017

    Hi All
    can any one send me the VCE player?
    can any one send me the VCE player
    can any one send me the VCE player

    Sopprusbarbosaatgmail.com

  47. Anonymous
    March 22nd, 2017

    I can’t see the questions even I am a premium member on 9tut. Anyone knows hy?

  1. No trackbacks yet.