Home > LACP with STP Sim

LACP with STP Sim

October 11th, 2018 in Lab Sim, LabSim Go to comments

Question

You work for SWITCH.com. They have just added a new switch (SwitchB) to the existing network as shown in the topology diagram.

LACP_STP_topology.jpg

RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA.
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.

Note: There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface

Answer and Explanation:

We post the initial configuration of Sw-A & Sw-B here for your reference, you can try solving this sim by yourself before reading the asnwers below:

Initial Configuration (useless lines have been removed)

SwA:
hostname Sw-A
!
vtp mode transparent
!
spanning-tree mode rapid-pvst
!
vlan 98
!
vlan 99
 name TrunkNative
!
interface FastEthernet0/1
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 98
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
end
Sw-B:
hostname Sw-B
!
vtp mode server
!
spanning-tree mode pvst
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.1.1
!
end

Solution

SW-A (close to router)
Note: If Sw-A does not have Vlan 11, 12, 13 we have to create them first with command “SW-A(config)#vlan 11,12,13”
SW-A(config)#vlan 21
SW-A(config)#vlan 22
SW-A(config)#vlan 23
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98 (These two commands must be deleted to form a trunking link)
SW-A(config-if)#switchport trunk encapsulation dot1q //Some reports say that this command does not work on SW-A so just ignore it
SW-A(config-if)#switchport mode trunk
SW-A(config-if)#switchport trunk native vlan 99
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown

Note: In practical when you apply commands under “interface port-channel 1”, the same commands will be automatically applied to the physical member interfaces (of port-channel 1) so you don’t need to type them under physical member interfaces again. But in this exam you should configure everything under physical interfaces as there is a requirement to do so.

——————————————————————————————–

SW-B (far from router)
SW-B(config)#vlan 21
SW-B(config-vlan)#name Marketing
SW-B(config-vlan)#exit

SW-B(config)#vlan 22
SW-B(config-vlan)#name Sales
SW-B(config-vlan)#exit

SW-B(config)#vlan 23
SW-B(config-vlan)#name Engineering
SW-B(config-vlan)#exit
SW-B(config)#vlan 99
SW-B(config-vlan)#name TrunkNative // not necessary to name it but just name it same as SwitchA
SW-B(config-vlan)#exit
SW-B(config)#interface range fa0/9 – 10
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 21
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/13 – 14
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 22
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/15 – 16
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 23
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#vtp mode transparent

SW-B(config)#spanning-tree mode rapid-pvst //Same as Sw-A

SW-B(config)#interface vlan 1
SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
SW-B(config-if)#no shutdown
SW-B(config-if)#exit

SW-B(config)#interface range fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Note: For Sw-B we have to set the 802.1q trunking protocol (switchport trunk encapsulation dot1q) before converting it into a trunk because it is a 3500 series (or higher) switch which supports both ISL and 802.1Q and we have to explicitly set which trunking protocol to be used. Sw-A is a 2900x series (or lower) switch and does not support ISL trunking protocol (802.1Q is the only supported trunking protocol) so we can apply “switchport mode trunk” directly.

———————————————————

Some guidelines for configuring SwitchA & SwitchB:

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
vlan …
name …
(VLANs must be created on both switches if not exist)
interface range fa0/x – y
switchport mode access
switchport access vlan
spanning-tree portfast
– SwitchB VTP mode needs to be the same as SwitchA. vtp mode transparent
– SwitchB must operate in the same spanning tree mode as SwitchA. spanning-tree mode rapid-pvst
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.
interface vlan 1
ip address 192.168.1.11 255.255.255.0

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
Note: Two above commands must be deleted first to form a trunking link.

Although the first requirement asks us to configure trunking but we can ignore this task because we only need to configure trunking under their Port-channel (in the next task)

– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans:
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
SW-A(config-if)#switchport trunk encapsulation dot1q
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown
– Trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link:
SW-A(config-if)#switchport mode trunk //unconditional trunking
SW-A(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches and make other VLANs to be tagged
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
—————————————
SW-B(config)#interface range Fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Some notes for this sim:
+ You should check the initial status of both switches with these commands: show vtp status (transparent mode on SwitchA and we have to set the same mode on SwitchB), show spanning-tree [summary] (rapid-pvst mode on SwitchA and we have to set the same mode on SwitchB), show vlan (check the native vlan and the existence of vlan99), show etherchannel 1 port-channel and show ip int brief (check if Port-channel 1 has been created and make sure it is up), show run (to check everything again).
+ When using “int range f0/x – y” command hit space bar before and after “-” otherwise the simulator does not accept it.
+ You must create VLAN 99 for the SwitchB. SwitchA already has VLAN 99 configured.
+ At the end, you can try to ping from SwitchB to RouterA (you can get the IP on RouterA via the show cdp neighbors detail on SwitchA), not sure if it can ping or not. If not, you can use the “ip default-gateway 192.168.1.1” on SwitchB.
+ The name of SwitchA and SwitchB can be swapped or changed so be careful to put your configuration into appropriate switch.

The following “show” commands should be used to verify the configuration:

+ show vlan (check if the VLANs and VLAN names are correct)
+ show interface trunk (check if physical and port-channel is in trunking mode; the native VLANs on two switches match; allowed VLANs are correct)
+ show etherchannel summary (check Etherchannel status and LACP mode)
+ show ip interface brief (make sure the configured ports are up/up)
+ show spanning-tree (check STP mode)
+ show spanning-tree detail (can be used to check PortFast on specific interface but not sure if this command is supported in the exam)
+ show vtp status
+ show run (verify everything again)

Other lab-sims in this site:

MLS and EIGRP Sim
VTP Lab 2
VTP Lab
Spanning Tree Lab Sim
AAAdot1x Lab Sim

Comments
Comment pages
1 64 65 66 67 68 119 52
  1. cenaido
    December 21st, 2016

    I passed the exam today with 895. All questions from 191q are true. Labs AAA is the same as put in this page, it isn’t necessary set : switchport mode access and switchport access vlan 20 in the interface f0/1. With respect LACP I had serius problem in switch B , because were impossible create channel-group, i was intended set the command i became the enable mode , so i learned que when press the character “C”, i leave config terminal . In that situation, I did’t configure the channel-group in the laboratory , but the remain of the exam GOOD. Thanks everyboby…..see you in T&S

  2. cenaido
    December 21st, 2016

    I almost forget, in the labs sims, exist the note in bold
    AAA: none access list NAMED is allow, Its the one change that must be done in the sim.
    LACP: All configuration must be in physical interfaces.

  3. Lola Hilliard
    December 22nd, 2016

    Thanks @Jennifer Wallace to recommend me https://www.examsbuzz.com/300-115-exam.html for my exam preparation, i passed my 300-101 exam
    i am so happy

  4. Salah Zanni
    December 23rd, 2016

    @lola Hilliard Could you send me the dump of 300-101 for route ?
    {email not allowed}

  5. Salah Zanni
    December 23rd, 2016

    @lola Hilliard Could you send me the dump of 300-101 for route ?

  6. NLK
    December 26th, 2016

    Someone send me 201q please. naylindore @ gmail .com

  7. Jake
    December 26th, 2016

    stop advertising websites. Just help people. If I pass on Wednesday I will provide everyone my dumps…hope they are valid. Good luck everyone.

  8. Xander
    December 27th, 2016

    Tomorrow will be my exam, if anyone have questions regarding the exam i will gladly help.

  9. Salah Zanni
    December 27th, 2016

    Hello all i passed with 895 point the dump 191q for 300-115 still valid till now 27-12-2016

  10. Salah Zanni
    December 27th, 2016

    @Xander this sim you will find it and you need to confirm the commands so #show ether channel summary (to see if the port channel up or down) #show interface trunk (to see if the native vlan existing on the trunk ports)

  11. Xander
    December 27th, 2016

    Hi, just passed 975!
    Thanks! Love you all guys!

    AAA, lacp, hsrp & cdp drag and drop.

  12. Jake
    December 27th, 2016

    taking exam tomorrow…I would appreciate dumps eigrp100 at gmail dot com

  13. dan
    December 29th, 2016

    AAA DOT 1X

    ASW(config)#aaa new-model
    ASW(config)#radius-server host 172.120.40.46 key rad 123 [provided IP in the exam]
    ASW(config)#aaa authentication dot1x defautl group radius
    ASW(config)#dot1x system-auth-control
    ASW(config)#int fa0/1
    ASW(config-if)#dot1x port-control auto
    ASW(config-if)#switchport mode access [was already there]
    ASW(config-if)#switchport access vlan 20
    ASW(config-if)#no shut
    ASW(config-if)#exit
    ASW#copy run start
    DSW
    DSW(config)#accesss-list 10 permit 172.120.40.0 0.0.0.255
    DSW(config-nacl)#exit
    DSW(config)#vlan access-map NAME 10
    DSW(config-vlan-map)#match ip address 10
    DSW(config-vlan-map)#action forward
    DSW(config-vlan-map)#exit
    DSW(config)#vlan access-map NAME 20
    DSW(config-vlan-map)#action drop
    DSW(config-vlan-map)#exit
    DSW(config)#vlan filter NAME vlan-list 20
    DSW#copy run start

  14. dan
    December 29th, 2016

    LACP with STP lab
    SW-A (close to router)
    Note: If Sw-A does not have Vlan 11, 12, 13 we have to create them first with command “SW-A(config)#vlan 11 ,
    SW-A(config)#vlan 12
    SW-A(config)#vlan 13
    CHECK THE NAMES in SW-B# sh run
    SW-A(config)#spanning-tree vlan 11-13,21-23 root primary
    SW-A(config)#vlan 21
    SW-A(config-vlan)#name Marketing
    SW-A(config-vlan)#exit
    SW-A(config)#vlan 22
    SW-A(config-vlan)#name Sales
    SW-A(config-vlan)#exit
    SW-A(config)#vlan 23
    SW-A(config-vlan)#name Engineering
    SW-A(config-vlan)#exit
    SW-A(config)#interface range fa0/3 – 4
    SW-A(config-if-range)#no switchport mode access
    SW-A(config-if-range)#no switchport access vlan 98
    SW-A(config-if-range)#channel-group 1 mode active
    SW-A(config-if-range)#channel-protocol lacp
    SW-A(config-if-range)# switchport mode trunk
    SW-A(config-if-range)# switchport trunk native vlan 99
    SW-A(config-if-range)# switchport trunk allowed vlan 1, 21-23
    SW-A(config-if-range)#no shutdown
    SW-A# copy run start
    SW-B (far from router)
    SW-B(config)#vlan 21
    SW-B(config-vlan)#name Marketing
    SW-B(config-vlan)#exit
    SW-B(config)#vlan 22
    SW-B(config-vlan)#name Sales
    SW-B(config-vlan)#exit
    SW-B(config)#vlan 23
    SW-B(config-vlan)#name Engineering
    SW-B(config-vlan)#exit
    SW-B(config)#vlan 99
    SW-B(config-vlan)#name TrunkNative
    SW-B(config-vlan)#exit
    SW-B(config)#interface range fa0/9 – 10
    SW-B(config-if-range)#switchport mode access
    SW-B(config-if-range)#switchport access vlan 21
    SW-B(config-if-range)#spanning-tree portfast
    SW-B(config-if-range)#no shutdown
    SW-B(config-if-range)#exit
    SW-B(config)#interface range fa0/13 – 14
    SW-B(config-if-range)#switchport mode access
    SW-B(config-if-range)#switchport access vlan 22
    SW-B(config-if-range)#spanning-tree portfast
    SW-B(config-if-range)#no shutdown
    SW-B(config-if-range)#exit
    SW-B(config)#interface range fa0/15 – 16
    SW-B(config-if-range)#switchport mode access
    SW-B(config-if-range)#switchport access vlan 23
    SW-B(config-if-range)#spanning-tree portfast
    SW-B(config-if-range)#no shutdown
    SW-B(config-if-range)#exit
    SW-B(config)#vtp mode transparent
    SW-B(config)#spanning-tree mode rapid-pvst
    SW-B(config)#interface vlan 1
    SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
    SW-B(config-if)#no shutdown
    SW-B(config-if)#exit
    SW-B(config)#interface range fa0/3 – 4
    SW-B(config-if-range)#Switchport trunk encapsulation dot1q
    SW-B(config-if-range)#channel-group 1 mode passive
    SW-B(config-if-range)#channel-protocol lacp
    SW-B(config-if-range)# switchport mode trunk
    SW-B(config-if-range)# switchport trunk native vlan 99
    SW-B(config-if-range)# switchport trunk allowed vlan 1, 21-23
    SW-B(config-if-range)#no shutdown
    SW-B# copy run start

  15. Anonymous
    December 29th, 2016

    PASSED today 916
    same as provided here
    good luck all

    #Thank_You_S

  16. Shriram
    December 29th, 2016

    Guys,

    Please share your mail ID on below mail so that i can sent you 191q dumps…
    shriramtrimal19 @ gmail dot com

  17. Just Passed
    December 29th, 2016

    All – just passed yesterday with 790. All questions were from here and Sims were AAAdot1X and LACP with STP – answers above by dan look good. If you know this site, you will pass.

  18. Jake
    December 29th, 2016

    I passed the switch exam with a 976. I got the ‘LACP with STP’ lab, AAAdot1x, VTP Lab 2 & HSRP SIM. I mostly studied every lab/sim & question on this website. Every question was from this website. The 191 dumps I kindly received were from Actual Tests Version 10. These dumps may have contained a few questions not on this website but almost identical so you don’t need them. The only change I made was to the “LACP with STP lab”. In this lab I put all the configuration settings under the interface (interface range fa0/3-4) not the port channel group. Every other answer came from this website. I am now a CCNP using this website.

  19. Anonymous
    December 30th, 2016

    I just passed 853 scores
    Q191 is still valid
    AAA Lacp-stp and HSRP, drag drop
    Good luck guys
    Now to routing

  20. FK
    December 31st, 2016

    I just sat for my switch exam this Friday morning, passed with 874- layer 2 technologies 88%, infrastructure security 100% and infrastructure services 88%. Q191 is valid with AAAdot1x, LACP with STP, Drag and drop, HSRP simlet. I couldn’t understand where it went wrong, there was a pruning request in the LACP though…going to Routing now. Thanks for the support and Good luck!!

  21. MILON
    December 31st, 2016

    Hi every one,

    Could any one help me. I attended the exam 300-115. Didn’t score enough. I had some issue if any one can suggest me for my next try.

    ON LACP with SAP simulation

    1.On sw_a I put all commands same like on top.

    2. On sw_b
    After configure vlan21_-23
    Then when I was trying to put below command
    SW-B(config)#vlan 99
    SW-B(config-vlan)#name TrunkNative
    SW-B(config-vlan)#exit

    there is an error message coming on the screen

    “”The connection between f0/3-4 lost””

    And every time I am Writing any command that error massage keeps coming up.

    Please advice me is that will be to finish all commands as it is like on top.

    Thanks and regards

  22. MILON
    December 31st, 2016

    Hi every one,

    Could any one help me. I attended the exam 300-115. Didn’t score enough. I had some issue if any one can suggest me for my next try.

    ON LACP with SAP simulation

    1.On sw_a I put all commands same like on top.

    2. On sw_b
    After configure vlan21_-23
    Then when I was trying to put below command
    SW-B(config)#vlan 99
    SW-B(config-vlan)#name TrunkNative
    SW-B(config-vlan)#exit

    there is an error message coming on the screen

    “”The connection between f0/3-4 lost””

    And every time I am Writing any command that error massage keeps coming up.

    Please advice me is that will be to finish all commands as it is like on top.

    One more thing it was not accepting this command on both switch (sw-a, sw-b)

    SW-B(config-if-range)#Switchport trunk encapsulation dot1q
    Thanks and regards

  23. MILON
    December 31st, 2016

    Hi every one,

    Could any one help me. I attended the exam 300-115. Didn’t score enough. I had some issue if any one can suggest me for my next try.

    ON LACP with SAP simulation

    1.On sw_a I put all commands same like on top.

    2. On sw_b
    After configure vlan21_-23
    Then when I was trying to put below command
    SW-B(config)#vlan 99
    SW-B(config-vlan)#name TrunkNative
    SW-B(config-vlan)#exit

    there is an error message coming on the screen

    “”The connection between f0/3-4 lost””

    And every time I am Writing any command that error massage keeps coming up.

    Please advice me is that will be to finish all commands as it is like on top.

    One more thing it was not accepting this command on both switch (sw-a, sw-b)

    SW-B(config-if-range)#Switchport trunk encapsulation dot1q.
    Thanks and regards

  24. Hiko
    January 2nd, 2017

    Anonymous please send valid dump to hikmetcisco @ gmail . com i am waiting

  25. Aamir
    January 3rd, 2017

    Hello..
    anyone please tell me..
    Is it necessary to complete all labs 100%?
    If i perform some task incomplete? Will I get marks?

  26. Keneth
    January 4th, 2017

    Took the exam and passed with score of more that 930. Good luck everyone!!!

  27. gabe
    January 4th, 2017

    Can someone please share latest dump to… der.oben @ gmx .de

  28. ????
    January 5th, 2017

    Lab LACP with STP:
    >> configuration ip default-gateway 192.168.1.1 ( config on SWB )

    Did anyone get the Lab full marks ?

    Question:
    Should ip default gateway be configured or not ?

  29. ????
    January 5th, 2017

    AMIR MY FRIEND

    Did you start configuring the switch close to the router 1st ?
    Was the switch close to router SWA ?
    Did you do no switchport mode access & no switchport mode access vlan 98 ?

    Answer to your question >> no even though you get some configs in the lab wrong say for example you get 20 % wrong and marks will be given for the 80 % completed.

    How well did you do your other labs ?
    Did you get all correct in your question & answers ?

  30. ott75
    January 5th, 2017

    hi,
    I got this error in the exam:
    switchport trunk encapsulation dot1q
    % Invalid input detected at ‘^’ marker.
    why?

Comment pages
1 64 65 66 67 68 119 52
  1. No trackbacks yet.