Home > LACP with STP Sim

LACP with STP Sim

October 11th, 2018 in Lab Sim, LabSim Go to comments

Question

You work for SWITCH.com. They have just added a new switch (SwitchB) to the existing network as shown in the topology diagram.

LACP_STP_topology.jpg

RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA.
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.

Note: There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface

Answer and Explanation:

We post the initial configuration of Sw-A & Sw-B here for your reference, you can try solving this sim by yourself before reading the asnwers below:

Initial Configuration (useless lines have been removed)

SwA:
hostname Sw-A
!
vtp mode transparent
!
spanning-tree mode rapid-pvst
!
vlan 98
!
vlan 99
 name TrunkNative
!
interface FastEthernet0/1
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 98
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
end
Sw-B:
hostname Sw-B
!
vtp mode server
!
spanning-tree mode pvst
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.1.1
!
end

Solution

SW-A (close to router)
Note: If Sw-A does not have Vlan 11, 12, 13 we have to create them first with command “SW-A(config)#vlan 11,12,13”
SW-A(config)#vlan 21
SW-A(config)#vlan 22
SW-A(config)#vlan 23
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98 (These two commands must be deleted to form a trunking link)
SW-A(config-if)#switchport trunk encapsulation dot1q //Some reports say that this command does not work on SW-A so just ignore it
SW-A(config-if)#switchport mode trunk
SW-A(config-if)#switchport trunk native vlan 99
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown

Note: In practical when you apply commands under “interface port-channel 1”, the same commands will be automatically applied to the physical member interfaces (of port-channel 1) so you don’t need to type them under physical member interfaces again. But in this exam you should configure everything under physical interfaces as there is a requirement to do so.

——————————————————————————————–

SW-B (far from router)
SW-B(config)#vlan 21
SW-B(config-vlan)#name Marketing
SW-B(config-vlan)#exit

SW-B(config)#vlan 22
SW-B(config-vlan)#name Sales
SW-B(config-vlan)#exit

SW-B(config)#vlan 23
SW-B(config-vlan)#name Engineering
SW-B(config-vlan)#exit
SW-B(config)#vlan 99
SW-B(config-vlan)#name TrunkNative // not necessary to name it but just name it same as SwitchA
SW-B(config-vlan)#exit
SW-B(config)#interface range fa0/9 – 10
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 21
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/13 – 14
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 22
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/15 – 16
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 23
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#vtp mode transparent

SW-B(config)#spanning-tree mode rapid-pvst //Same as Sw-A

SW-B(config)#interface vlan 1
SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
SW-B(config-if)#no shutdown
SW-B(config-if)#exit

SW-B(config)#interface range fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Note: For Sw-B we have to set the 802.1q trunking protocol (switchport trunk encapsulation dot1q) before converting it into a trunk because it is a 3500 series (or higher) switch which supports both ISL and 802.1Q and we have to explicitly set which trunking protocol to be used. Sw-A is a 2900x series (or lower) switch and does not support ISL trunking protocol (802.1Q is the only supported trunking protocol) so we can apply “switchport mode trunk” directly.

———————————————————

Some guidelines for configuring SwitchA & SwitchB:

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
vlan …
name …
(VLANs must be created on both switches if not exist)
interface range fa0/x – y
switchport mode access
switchport access vlan
spanning-tree portfast
– SwitchB VTP mode needs to be the same as SwitchA. vtp mode transparent
– SwitchB must operate in the same spanning tree mode as SwitchA. spanning-tree mode rapid-pvst
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.
interface vlan 1
ip address 192.168.1.11 255.255.255.0

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
Note: Two above commands must be deleted first to form a trunking link.

Although the first requirement asks us to configure trunking but we can ignore this task because we only need to configure trunking under their Port-channel (in the next task)

– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans:
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
SW-A(config-if)#switchport trunk encapsulation dot1q
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown
– Trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link:
SW-A(config-if)#switchport mode trunk //unconditional trunking
SW-A(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches and make other VLANs to be tagged
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
—————————————
SW-B(config)#interface range Fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Some notes for this sim:
+ You should check the initial status of both switches with these commands: show vtp status (transparent mode on SwitchA and we have to set the same mode on SwitchB), show spanning-tree [summary] (rapid-pvst mode on SwitchA and we have to set the same mode on SwitchB), show vlan (check the native vlan and the existence of vlan99), show etherchannel 1 port-channel and show ip int brief (check if Port-channel 1 has been created and make sure it is up), show run (to check everything again).
+ When using “int range f0/x – y” command hit space bar before and after “-” otherwise the simulator does not accept it.
+ You must create VLAN 99 for the SwitchB. SwitchA already has VLAN 99 configured.
+ At the end, you can try to ping from SwitchB to RouterA (you can get the IP on RouterA via the show cdp neighbors detail on SwitchA), not sure if it can ping or not. If not, you can use the “ip default-gateway 192.168.1.1” on SwitchB.
+ The name of SwitchA and SwitchB can be swapped or changed so be careful to put your configuration into appropriate switch.

The following “show” commands should be used to verify the configuration:

+ show vlan (check if the VLANs and VLAN names are correct)
+ show interface trunk (check if physical and port-channel is in trunking mode; the native VLANs on two switches match; allowed VLANs are correct)
+ show etherchannel summary (check Etherchannel status and LACP mode)
+ show ip interface brief (make sure the configured ports are up/up)
+ show spanning-tree (check STP mode)
+ show spanning-tree detail (can be used to check PortFast on specific interface but not sure if this command is supported in the exam)
+ show vtp status
+ show run (verify everything again)

Other lab-sims in this site:

MLS and EIGRP Sim
VTP Lab 2
VTP Lab
Spanning Tree Lab Sim
AAAdot1x Lab Sim

Comments
Comment pages
1 65 66 67 68 69 52
  1. ABC
    June 4th, 2019

    Hi Mngr,
    Can you give me dump ccnp sw 300-125. pls.

  2. Lolo@23
    June 5th, 2019

    Hi,

    Does anyone have the latest dumps.

    Or Does certprepare have a login sites you pay for ,for the latest dumps?

    Anybody please enlighten me.

    Thanks

  3. Sky
    June 6th, 2019

    @MrG
    Because f0/1 is an actual access port. we are deleting from 3 and 4 because we are converting them to trunk ports

  4. lislabo
    June 8th, 2019

    Hi, can you kindly share CCNP SWITCH 300-115 dump premium file to (( lislaboo@gmail . com ))
    I have exams next week
    Thank You.

  5. kkdabs
    June 11th, 2019

    Kindly share CCNP Switch 300-115 dumps with me also (opedabs1 @ gmail .com)

  6. kkdabs
    June 11th, 2019

    CAn someone share the lab simulation files in GNS3 or packet tracer with me.

    (opedabs1 @ gmail .com)

    Thank you.

  7. Ranthom
    June 12th, 2019

    We value your huge exam fee, WAY to your Success.

    CCNA R&S
    CCNP ROUTE
    CCNP SWITCH
    CCNP TSHOOT
    CCIE WRITTEN

    At web : Remove spaces
    eze e.l ink/3iAMgBsRHo

  8. IP helper
    June 12th, 2019

    @kkdabs, @lislabo: you can contact me for dump: networkdummies(at)gmail(dot)com

  9. Somkak7
    June 16th, 2019

    Hi everyone.
    Can someone tell me if the ping is working for the lacp lab? My pings are failing. Need your help

  10. Anonymous
    June 23rd, 2019

    CCNP Switch DUMP plz.
    ({email not allowed})

  11. confused
    June 26th, 2019

    hi everyone….which labs to study??

    exam passers say hsrp lab, i cant find on site, only stp with lacp??

    which vtp3 lab?? on site there only vtp and vtp 2 lab?? please help me

  12. Headwig
    June 27th, 2019

    I would say you need the AAA lab it seems to come up very often

  13. kushi
    June 28th, 2019

    hello

  14. kushi
    June 28th, 2019

    pls share ccnp switch dump
    k6206700 at gmail

  15. Anonymous
    July 3rd, 2019

    Hi, can you kindly share CCNP SWITCH 300-115 dump premium file to ((fcb.riga.ryota @gmail . com ))
    I have exams next week
    Thank You.

  16. Anonymous
    July 3rd, 2019

    Hi, Please anyone share CCNP Latest dump file

    eriqedwin@ gmail . com

  17. Need help
    July 3rd, 2019

    Hi
    it is said in SW A switchport trunk encapsulation dot1q will not work however, in SW B as well showing invalid error as below (Cert prepare packet tracer)

    Sw_B(config)#int ra fa0/3-4
    Sw_B(config-if-range)#switchport trunk encapsulation dot1q
    ^
    % Invalid input detected at ‘^’ marker.

    Sw_B(config-if-range)#switchport mode trunk

    Sw_B(config-if-range)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

    Please, suggest will this command go through in real exam , I have exam on the 4 th July 2019

  18. Anonymous
    July 3rd, 2019

    command switchport trunk encapsulation dot1q

    show be on SW_A no SW_B

    ^

  19. BryanD
    July 6th, 2019

    @kkdabs, @lislabo: you can email me for Routing and switching 2019 dumps

    bryandiazbd430 @ gmail . com

  20. No AAA in exam
    July 8th, 2019

    I took the test and surprisingly failed got 500/1000, out of 44 38 questions (15 q from SPAN/RSPAN alone statements True? and Choose 2) came from below not usual may be they have different sets of test papers?

    – Last Thursday 4th July exam, only LACP STP , HRSP , vtp was common no AAA/drag drop ! rest 38 questions from below topics (never saw them while I took exam in 2016 two times)
    -I have only 7 more days/expire

    -Any suggestions shall I change the Test center ?and sit on different day? to get a different set of questions ?which has (LACP STP, AAA dot1x , HRSP, vtp , Core, drag and drop )

    – Please, advice , very afraid now.

    – Rest came from
    Rest 38 questions from below topics

    STP /LACP
    HRSP
    VTP3
    MOST OF THEM CHOOSE 2 BELOW
    RADIUS + TACACS CH 3
    SPAN/RSPAN (15 Questions TRUE ABOUT / choose two)
    ULDD
    GLBB True abt it
    IF BPDU FAILS
    SLACK MASTER
    MIS
    MST stacking
    STACKING
    UNIDIRECTIONAL AT Q END
    SDM

  21. No AAA in exam
    July 8th, 2019

    Also to add the 143 q from reputed guarantee pass also did not have any thing in common this Thursday exam 4th July

  22. Pachekz
    July 9th, 2019

    I took the exam the las 1Jul, and Fail.-.- 6xx/1000. I purchase the premium dump for Pass4sure, and all question are NEW.

  23. @ Pachekz
    July 10th, 2019

    @ Pachekz so the premium dump from pass4sure (143 q) did not have anything common right?
    Please, elaborate on what topics (choose two ) and LACP but no AAA right ?
    will you take the exam again ?

  24. Eriq
    July 10th, 2019

    @No AAA in exam and @Pachekz,
    Brothers can you please help me out, I am also take exam on this month, 24th july.
    My Cert also expire on 28 july i am very afraid. Please help me out.

  25. Eriq
    July 10th, 2019

    Please send some valid dumps,

    Eriqedwin @ gmail .com

  26. @Eriq
    July 10th, 2019

    I got dums from pas4sure 143q nothing common
    bought from iphelper {email not allowed} dums at $ 18 has 800+ questions looks similar + read book similar topic q from No AAA above 38 out of 44 inc LACP stp

  27. Eriq
    July 11th, 2019

    @No AAA in exam and @Pachekz,
    I have Iphelper 1149q is this valid dump?
    I can share with you, send me your email..

    Eriqedwin @ gmail.com

  28. jihad
    July 11th, 2019

    Just passed the exam today with 9xx, SIMS: HSRP, VTPv3, and LACP.
    I did not encounter any D&D.
    all the questions here are valid more on Infrastructure Security, lots of radius/tacacs, lots of bpdu concepts (e.g. root guard, loop guard etc) and RSPAN.

    I do not know if I am correct with TACACS+ but I am in between client-server application and client-private cloud (this was choose three, the other two choices were easy but this was I got confused). anyhow, better check this on the forum.

    goodluck to everyone!

  29. Anonymous
    July 15th, 2019

    Some please share if there are any updated dumps available !!
    pls share ccnp 300-115 switch dump !!!!
    Alessandro_rios @ outlook com

  30. QuornGato
    July 15th, 2019

    Hey gents,
    Barely passed this one. The was a tough test.
    Labs: HSRP, VTPv3, LACP with STP sim
    I’ve been getting the error on the sim:

    Sw_B(config)#int ra fa0/3-4
    Sw_B(config-if-range)#switchport trunk encapsulation dot1q
    ^
    % Invalid input detected at ‘^’ marker.

    I think this might be a DTP issue.
    To fix this, I tried changing the port to access first, then using the encapsulation, then turning the interface range to a trunk port. It seemed to work okay.

    So the commands were in this order:
    Sw_B(config)#int ra fa0/3-4
    Sw_B(config-if-range)#switchport mode access
    Sw_B(config-if-range)#switchport trunk encapsulation dot1q
    Sw_B(config-if-range)#switchport mode trunk
    SW-B(config-if)#switchport trunk native vlan 99
    SW-B(config-if)#switchport trunk allowed vlan 1,21-23
    SW-B(config-if)#channel-group 1 mode passive
    SW-B(config-if)#channel-protocol lacp
    SW-B(config-if)#no shutdown

    This worked for me, hopefully will work for you guys.
    Had 2 drag and drop questions (SNMP, CDP).
    Questions were UDLD, SPAN, RSPAN, AAA/TACAS+, Etherchannel config, native VLANs, root guard config.

    Best of luck guys!

  31. Anonymous
    July 15th, 2019

    Some please share if there are any updated dumps available !!
    Alessandro_rios @ outlook com

  32. gang
    July 16th, 2019

    Please share latest 300-115 dump

    fumani . maluleke @ gmail . com

  33. Kyaw
    July 17th, 2019

    Hello , if anyone had latest 300-115 Dump pls share me : {email not allowed}

  34. Kyaw
    July 17th, 2019

    Hello , if anyone had latest 300-115 Dump pls share me : kyawzin . 4989 @ gmail . com

  35. QuornGato
    July 17th, 2019

    btw who needs IP helper July can reach me at: cisco4career @ gmail . com
    Good luck all!

  36. CCN-Chaser
    July 17th, 2019

    @QuornGato did you study through this site or you had other material.

  37. Muneef
    July 18th, 2019

    Wish me luck i am taking the test next week regarding this question i beleive we need to add

    switchport trunk allowed vlan 1,21-23 to the port channel interface too what do you think ?

  38. Anonymous
    July 19th, 2019

    Please share me latest dumps chocvea @ gmail. com

  39. zxc
    July 20th, 2019

    I tried to simulate this exam, is it normal that i cant ping anything from router and vice versa?

  40. zxc
    July 20th, 2019

    is it normal that vlan 1 is in shutdown?

  41. Next Week
    July 20th, 2019

    How do you know What mod version the sim is running? Meaning do we have to configure the port channel or just to the interfaces?

  42. Next Week
    July 21st, 2019

    It depends on the question, if the question said configure in port then configure it in port only

  43. @GK
    July 21st, 2019

    Passed SWITCH exam on 18th. These Dumps are still valid. Got LACP with STP Sim

  44. help
    July 22nd, 2019

    give dump pls

  45. SpeerGag
    July 22nd, 2019

    Please share latest 300-115 dump with me mikeuthoff @ yahoo . com

  46. Ark
    July 22nd, 2019

    Hi, i tried to simulate certprepare lacp sim here but i cant ping 192.168.1.1 on swB when configuring it under physical interfaces. But when configuring it under port channel, i can ping it. Is that normal?

  47. Ark
    July 22nd, 2019

    @GK have you configured it on the physical interface?

  48. Anonymous
    July 23rd, 2019

    I fail today.

    I have braindumps 143q dump and all question new.

    Please, share dump valid with me: albcombo @ gmail . com

    Thanks.

  49. Failed
    July 25th, 2019

    Failed today,alot of tacacs span multiple question,,this lab come up.. i cannot make interface range fa0/3-4 said invalid command..what i did is manually configured trunk port one by one..
    score
    62
    58
    100 failed score 770 passing 790

  50. Sorry
    July 25th, 2019

    Failed this day, score 770,i have lacp+stp,hsrp sim,vtpv3.. alotof new question in multiple choice mostly new thats why im doubt for my answer in multiple choice.2drag annd drop.UDLD, SPAN, RSPAN, AAA/TACAS+, Etherchannel config, native VLANs, root guard config.

Comment pages
1 65 66 67 68 69 52
  1. No trackbacks yet.