Home > LACP with STP Sim

LACP with STP Sim

October 11th, 2018 in Lab Sim, LabSim Go to comments

Question

You work for SWITCH.com. They have just added a new switch (SwitchB) to the existing network as shown in the topology diagram.

LACP_STP_topology.jpg

RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA.
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.

Note: There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface

Answer and Explanation:

We post the initial configuration of Sw-A & Sw-B here for your reference, you can try solving this sim by yourself before reading the asnwers below:

Initial Configuration (useless lines have been removed)

SwA:
hostname Sw-A
!
vtp mode transparent
!
spanning-tree mode rapid-pvst
!
vlan 98
!
vlan 99
 name TrunkNative
!
interface FastEthernet0/1
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 98
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
end
Sw-B:
hostname Sw-B
!
vtp mode server
!
spanning-tree mode pvst
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.1.1
!
end

Solution

SW-A (close to router)
Note: If Sw-A does not have Vlan 11, 12, 13 we have to create them first with command “SW-A(config)#vlan 11,12,13”
SW-A(config)#vlan 21
SW-A(config)#vlan 22
SW-A(config)#vlan 23
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98 (These two commands must be deleted to form a trunking link)
SW-A(config-if)#switchport trunk encapsulation dot1q //Some reports say that this command does not work on SW-A so just ignore it
SW-A(config-if)#switchport mode trunk
SW-A(config-if)#switchport trunk native vlan 99
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown

Note: In practical when you apply commands under “interface port-channel 1”, the same commands will be automatically applied to the physical member interfaces (of port-channel 1) so you don’t need to type them under physical member interfaces again. But in this exam you should configure everything under physical interfaces as there is a requirement to do so.

——————————————————————————————–

SW-B (far from router)
SW-B(config)#vlan 21
SW-B(config-vlan)#name Marketing
SW-B(config-vlan)#exit

SW-B(config)#vlan 22
SW-B(config-vlan)#name Sales
SW-B(config-vlan)#exit

SW-B(config)#vlan 23
SW-B(config-vlan)#name Engineering
SW-B(config-vlan)#exit
SW-B(config)#vlan 99
SW-B(config-vlan)#name TrunkNative // not necessary to name it but just name it same as SwitchA
SW-B(config-vlan)#exit
SW-B(config)#interface range fa0/9 – 10
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 21
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/13 – 14
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 22
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/15 – 16
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 23
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#vtp mode transparent

SW-B(config)#spanning-tree mode rapid-pvst //Same as Sw-A

SW-B(config)#interface vlan 1
SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
SW-B(config-if)#no shutdown
SW-B(config-if)#exit

SW-B(config)#interface range fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Note: For Sw-B we have to set the 802.1q trunking protocol (switchport trunk encapsulation dot1q) before converting it into a trunk because it is a 3500 series (or higher) switch which supports both ISL and 802.1Q and we have to explicitly set which trunking protocol to be used. Sw-A is a 2900x series (or lower) switch and does not support ISL trunking protocol (802.1Q is the only supported trunking protocol) so we can apply “switchport mode trunk” directly.

———————————————————

Some guidelines for configuring SwitchA & SwitchB:

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
vlan …
name …
(VLANs must be created on both switches if not exist)
interface range fa0/x – y
switchport mode access
switchport access vlan
spanning-tree portfast
– SwitchB VTP mode needs to be the same as SwitchA. vtp mode transparent
– SwitchB must operate in the same spanning tree mode as SwitchA. spanning-tree mode rapid-pvst
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.
interface vlan 1
ip address 192.168.1.11 255.255.255.0

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
Note: Two above commands must be deleted first to form a trunking link.

Although the first requirement asks us to configure trunking but we can ignore this task because we only need to configure trunking under their Port-channel (in the next task)

– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans:
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
SW-A(config-if)#switchport trunk encapsulation dot1q
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown
– Trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link:
SW-A(config-if)#switchport mode trunk //unconditional trunking
SW-A(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches and make other VLANs to be tagged
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
—————————————
SW-B(config)#interface range Fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Some notes for this sim:
+ You should check the initial status of both switches with these commands: show vtp status (transparent mode on SwitchA and we have to set the same mode on SwitchB), show spanning-tree [summary] (rapid-pvst mode on SwitchA and we have to set the same mode on SwitchB), show vlan (check the native vlan and the existence of vlan99), show etherchannel 1 port-channel and show ip int brief (check if Port-channel 1 has been created and make sure it is up), show run (to check everything again).
+ When using “int range f0/x – y” command hit space bar before and after “-” otherwise the simulator does not accept it.
+ You must create VLAN 99 for the SwitchB. SwitchA already has VLAN 99 configured.
+ At the end, you can try to ping from SwitchB to RouterA (you can get the IP on RouterA via the show cdp neighbors detail on SwitchA), not sure if it can ping or not. If not, you can use the “ip default-gateway 192.168.1.1” on SwitchB.
+ The name of SwitchA and SwitchB can be swapped or changed so be careful to put your configuration into appropriate switch.

The following “show” commands should be used to verify the configuration:

+ show vlan (check if the VLANs and VLAN names are correct)
+ show interface trunk (check if physical and port-channel is in trunking mode; the native VLANs on two switches match; allowed VLANs are correct)
+ show etherchannel summary (check Etherchannel status and LACP mode)
+ show ip interface brief (make sure the configured ports are up/up)
+ show spanning-tree (check STP mode)
+ show spanning-tree detail (can be used to check PortFast on specific interface but not sure if this command is supported in the exam)
+ show vtp status
+ show run (verify everything again)

Other lab-sims in this site:

MLS and EIGRP Sim
VTP Lab 2
VTP Lab
Spanning Tree Lab Sim
AAAdot1x Lab Sim

Comments
Comment pages
1 66 67 68 69 52
  1. Ark
    July 25th, 2019

    Can anyone past the full commands they configured for LACP? Thanks!

  2. Passed today
    July 25th, 2019

    Passed. This Lab, HSRP Sim, and VTPv3 Sim came.
    Range command doesn’t work properly. Even though instruction in the exam says use space after ‘-‘, but sometimes it works, sometimes it doesn’t. Even after the command was accepted, it didn’t take effect. Finally configured interfaces individually.
    Few new questions. A couple of incorrect questions (missing word, incorrect command option). Used comment section to explain my answer.

  3. Ark
    July 25th, 2019

    hi passed today, did you used the same commands for lacp here?
    also, are you able to ping 192.168.1.1 on SWB?

  4. TakingExamOnSept
    July 26th, 2019

    Currently studying for September exam wish me luck

  5. Mark
    July 29th, 2019

    Please guide me who pass recently or any one knows in lab LACP with stp is it will mention in requirement ??? so we will be sure which one to do

    “There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface”

  6. janet
    July 30th, 2019

    Hi, can you kindly share CCNP SWITCH 300-115 dump premium file to ((jmasshoor @ gmail.com)).
    thanks.

  7. Navarro
    July 30th, 2019

    @Mark,

    I’m with same doubts;

    The commands to raise Etherchannel must be apply on physical interface or just in Port Channel?

  8. Kuzi
    July 31st, 2019

    Hi

    Can you please send the valid switch 300-115 dump to my mail.

    kuzipj69 @ gmail . com

    Best regards

  9. Noprobl
    July 31st, 2019

    I passed the exam yesterday.
    80% questions come up.
    HSRP Sim, LACP with STP , VTP 3
    A lot question on RSPAN, dhcp snooping, VTP, HSRP, CDP, LLDP

    Thanks

  10. RB1000
    July 31st, 2019

    I passed the exam today, the score is 900, I have the right dump, my email mkm963 at outlook. com

  11. Noprobl
    August 1st, 2019

    email me for valid July 2019 dump: cisco4career @ gmail . com

  12. Anonymous
    August 2nd, 2019

    hi everybody,

    please RB1000 email me the valid Dumps at {email not allowed}

    so urgent !!!

  13. Bryan
    August 5th, 2019

    Hi, I’m proud to announce that I passed the CCNP – Switching just today. I use the CCNP-Switching 2019 dump file. If you want materials I used, just email me. bryandiazbd 430 @ gmail .com

  14. Core
    August 10th, 2019

    Passed Yesterday with 867. All questions from Dumps (Little Modifications)
    Lab- HSRP (With Interface to R5). VTP V3. LACP with STP (After all Configurations, 3 vlan interfaces didn’t come up).

  15. Ray
    August 11th, 2019

    Can someone please post the link to the questions PDF here?

  16. Navarro
    August 13th, 2019

    All Config must be applied in physical interface and not in Port-Channel?

  17. edd
    August 14th, 2019

    VLAN 1 in Switch-A is Shutdown, so we can’t ping Router-A
    They don’t say to do “no shutdown” in VLAN 1 of Switch-A

  18. jcan
    August 14th, 2019

    Failed again and frustrated. I spent 40 minutes on this SIM with some variations on the SIM that I tried to unsuccessfully lab in my gns3 enivronment. I realized 1 of the 3 things I did not understand correctly however the 2nd and 3rd issue I’m stuck on. Help me out. The default vlan was vlan98 on SwitchA and it required I of course change the default to vlan99 on switchA and switchB to allow the etherchannel to work. No problem, but then the SIM required that the default vlan be tagged. I honestly didn’t know the correct command to apply therefor, I failed. My bad. Fine, now I’ve researched this issue and I believe the correct command at the global level should have been “config(#)vlan dot1q tag native”. I can’t seem to get any of my gns3 multilayer switches to recognize this command. Is this command correct or am I missing something??

    Also, the SIM required that I should only have allowed vlans 1,11-13 and 21-23 on SwitchA but it did not require that I create missing vlans 11-13 on switchb, it only required I create vlans 21-23 on switchb. I initially configured vlans 11-13 on switchb and then configured the “switchport trunk allowed vlans 1,11-13,21-23 to both etherchannel interfaces with unsuccessful results. I tried to reverse the vlan commands on switchb with the word “no” in front of them but the sim did’nt except the no commands.

    Finally: should I shut down the physical interfaces before I apply my etherchannel commands? Or, will the SIM break and not recognize shut and no shut commands. Thanks. Any input appreciated

  19. noleg
    August 14th, 2019

    hi, can anyone send me the dump file at noging hotmail .com

  20. Yaz
    August 15th, 2019

    Hi , could anyone please tell me where can i get SWITCH_Mar_2019.pdf ?
    My exam is on 1st Sept.
    Thank you.

  21. CCNPSwitchGirl
    August 16th, 2019

    Passed today! SIMs are still valid. Mine was HSRP, LACP and VTP.

    As for the Multiple choices, a lot of new questions for me which I did not see here so make sure you study and understand the concept well.

    Prep tools: CBT, How to Master CCNP switch, Certprepare premium

  22. Anonymous
    August 18th, 2019

    Hi Bryan,

    Please send your study material to openitland @ gmail .com

    Thanks,

  23. Portfast
    August 18th, 2019

    @CCNPSwitchGirl congraats
    I am aslo using CBT, How to Master CCNP switch, Certprepare premium can you please advise how valid is 300-115_IPHelper_July_2019 or SWITCH_Jul_2019

    I have an exam 1st week of September

  24. J
    August 23rd, 2019

    I am planning to re-certify my CCNP , i really don’t have the time to go through all the material again as i hold down full time employment does anyone have the latest dumps as i plan to write in September ?

  25. J-O
    August 23rd, 2019

    How to check this lab successful config ?

  26. Anonymous1
    August 24th, 2019

    Passed today with 834. Thanks a lot Certprepare for these study materials!

  27. Oxymoron
    August 25th, 2019

    – The VTP and STP configuration modes on SwitchA should not be modified.
    so no SW-A(config)#spanning-tree vlan 11-13,21-23 root primary
    instead Sw-B(config)#spanning-tree vlan 11-13,21-23 priority 36864

    SW-A(config-if)#switchport trunk encapsulation dot1q //Some reports say that this command does not work on SW-A so just ignore it newer switches just assume dot1Q, freaked me out when I first saw the command fail in the field.

  28. Oxymoron
    August 25th, 2019

    SW-A(config-if)#channel-group 1 mode active
    SW-A(config-if)#channel-protocol lacp
    this will give you some bizarre results, it will automatically build a one-legged port channel unless you complete building the port channel interface. The Po will show up in sho int trunk and show etherchannel. If we are not to use port channel, a better way is to load balance vlans across both individual trunks by pruning (sw trunk allowed vlan )
    Sw-A and Sw-B(config)#interface fa0/3
    Sw-A and Sw-B(config-if)#sw trunk allowed vlan 1,21
    Sw-A and Sw-B(config)#interface fa0/4
    Sw-A and Sw-B(config-if)#sw trunk allowed vlan 22,23

  29. Oxymoron
    August 25th, 2019

    Oh, I get it…
    Note: There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface

    this isn’t saying not to build a port channel but not build it with “Interface Po1”. Po1 has to learn from it’s subs and all the trunk commands will fill in themselves.

    Did Cisco invent Trivial Pursuit? I’ve been doing this for years and never would I do what they are looking for in these “certifications”. This certifies you can remember a bunch of stupid crap.

  30. Oxymoron
    August 25th, 2019

    My 1 legged port channel was caused by a flakey cable. Just what I needed!

  31. BusyBee
    August 26th, 2019

    may I request anyone please send me the latest dump for this paper? I will be grateful. my contact is z.fly.wat at gmail.com
    many thanks

  32. ivan
    August 27th, 2019

    why the allowed vlan command isn’t “switchport trunk allowed vlan 1,11-13,21-23” ???

  33. Maggot
    August 27th, 2019

    Hey, Some people refer to dumps but I’m not sure which ones are the correct ones to study?? I have SWITCH_Mar_2019, IPHelper_May_2019-PDF and 300-115 valid from Keyur. All are huge… I would love if people could validate which is best to study???

  34. Ginger
    September 1st, 2019

    Which dumps are still valid. Have exam coming up soon.

  35. Rob
    September 2nd, 2019

    do we really need to specify vlan 1 in trunk allowed list?

  36. Anonymous
    September 3rd, 2019

    CCNPSwitchGirl Could you please send me dump to bluemooncanada2019 at g mail. Thanks in advance. my exam is in sept last week.

  37. Fabdot
    September 8th, 2019

    Ho, anyone send me the last dumps files at fabio.dit @ inwind dot it???

  38. Scrabbler
    September 8th, 2019

    Thanks to CERT passed with 856 points. This is a tough test a few new questions and variations on original questions, the SIMs haven’t changed. Majority of questions are from this site. I’d recommend that you fully understand all layer 2 technologies and that you’re well prepared before taking the test.

  39. Fzkhan
    September 9th, 2019

    Hi, Please send me the latest dump on fzkhan at gmail dot com

  40. Dmytro
    September 9th, 2019

    Sorry, but I didn’t understand why we allowed VLAN 1 in trunk but not 99, if we set it as native?

  41. Henry
    September 9th, 2019

    Hi guys, passed my CCNP switch with 934. Thanks to Certprepare.
    This lab is one of them that came out. But Swith B need to type in Switchport trunk encapsulation dot1q.
    And VTP and HSRP. There are only 44 questions. Strange no drag and drop. Now preparing CCNP routing.

  42. Networker58
    September 9th, 2019

    Failed with 688 because of this lab I reckon the ports on switch A wouldnt accept the switchport trunk encapsulation dot1q command, I have raised a case with the test provider to confirm

  43. Anonymous
    September 9th, 2019

    in exam does the ping goes on physical port ?

  44. Anonymous
    September 9th, 2019

    you can send pings between the SVI’s, i got the etherchannel up and running but I realise now i didnt apply the native vlan to the trunk

  45. Henry
    September 10th, 2019

    Yes, Networker58. Switch A doesn’t accept that command but have to configure switch B with that command.

  46. need help
    September 10th, 2019

    just passed the exam, the dumps are valid.

  47. lets GET ITTTTTTT
    September 10th, 2019

    PASSED WITH 954, came this lab (on physical interface), total 44 dumps and no drag and drops

  48. gns3
    September 10th, 2019

    has anyone made these sims on gns3 or packettracer?

  49. Nate
    September 11th, 2019

    Please send any dumps you have to theonlybada ssisme at yahoo dot com

  50. CCNP
    September 11th, 2019

    how do we know that vlan should be the native Vlan for SWA?

Comment pages
1 66 67 68 69 52
  1. No trackbacks yet.