Home > LACP with STP Sim

LACP with STP Sim

October 11th, 2018 in Lab Sim, LabSim Go to comments

Question

You work for SWITCH.com. They have just added a new switch (SwitchB) to the existing network as shown in the topology diagram.

LACP_STP_topology.jpg

RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. SwitchA is currently configured correctly, but will need to be modified to support the addition of SwitchB. SwitchB has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchA.
– SwitchB must operate in the same spanning tree mode as SwitchA.
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.

Note: There is a requirement that the trunk between SwitchA and SwitchB must be configured under physical interfaces, not logical port-channel interface

Answer and Explanation:

We post the initial configuration of Sw-A & Sw-B here for your reference, you can try solving this sim by yourself before reading the asnwers below:

Initial Configuration (useless lines have been removed)

SwA:
hostname Sw-A
!
vtp mode transparent
!
spanning-tree mode rapid-pvst
!
vlan 98
!
vlan 99
 name TrunkNative
!
interface FastEthernet0/1
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 98
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 98
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
end
Sw-B:
hostname Sw-B
!
vtp mode server
!
spanning-tree mode pvst
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.1.1
!
end

Solution

SW-A (close to router)
Note: If Sw-A does not have Vlan 11, 12, 13 we have to create them first with command “SW-A(config)#vlan 11,12,13”
SW-A(config)#vlan 21
SW-A(config)#vlan 22
SW-A(config)#vlan 23
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98 (These two commands must be deleted to form a trunking link)
SW-A(config-if)#switchport trunk encapsulation dot1q //Some reports say that this command does not work on SW-A so just ignore it
SW-A(config-if)#switchport mode trunk
SW-A(config-if)#switchport trunk native vlan 99
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown

Note: In practical when you apply commands under “interface port-channel 1”, the same commands will be automatically applied to the physical member interfaces (of port-channel 1) so you don’t need to type them under physical member interfaces again. But in this exam you should configure everything under physical interfaces as there is a requirement to do so.

——————————————————————————————–

SW-B (far from router)
SW-B(config)#vlan 21
SW-B(config-vlan)#name Marketing
SW-B(config-vlan)#exit

SW-B(config)#vlan 22
SW-B(config-vlan)#name Sales
SW-B(config-vlan)#exit

SW-B(config)#vlan 23
SW-B(config-vlan)#name Engineering
SW-B(config-vlan)#exit
SW-B(config)#vlan 99
SW-B(config-vlan)#name TrunkNative // not necessary to name it but just name it same as SwitchA
SW-B(config-vlan)#exit
SW-B(config)#interface range fa0/9 – 10
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 21
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/13 – 14
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 22
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#interface range fa0/15 – 16
SW-B(config-if-range)#switchport mode access
SW-B(config-if-range)#switchport access vlan 23
SW-B(config-if-range)#spanning-tree portfast
SW-B(config-if-range)#no shutdown
SW-B(config-if-range)#exit

SW-B(config)#vtp mode transparent

SW-B(config)#spanning-tree mode rapid-pvst //Same as Sw-A

SW-B(config)#interface vlan 1
SW-B(config-if)#ip address 192.168.1.11 255.255.255.0
SW-B(config-if)#no shutdown
SW-B(config-if)#exit

SW-B(config)#interface range fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive //mode passive because “SwitchA controlling activation”
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Note: For Sw-B we have to set the 802.1q trunking protocol (switchport trunk encapsulation dot1q) before converting it into a trunk because it is a 3500 series (or higher) switch which supports both ISL and 802.1Q and we have to explicitly set which trunking protocol to be used. Sw-A is a 2900x series (or lower) switch and does not support ISL trunking protocol (802.1Q is the only supported trunking protocol) so we can apply “switchport mode trunk” directly.

———————————————————

Some guidelines for configuring SwitchA & SwitchB:

Configuration Requirements for SwitchA

– The VTP and STP configuration modes on SwitchA should not be modified.
– SwitchA needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values
SW-A(config)#spanning-tree vlan 11-13,21-23 root primary

Configuration Requirements for SwitchB

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
vlan …
name …
(VLANs must be created on both switches if not exist)
interface range fa0/x – y
switchport mode access
switchport access vlan
spanning-tree portfast
– SwitchB VTP mode needs to be the same as SwitchA. vtp mode transparent
– SwitchB must operate in the same spanning tree mode as SwitchA. spanning-tree mode rapid-pvst
– No routing is to be configured on SwitchB.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.
interface vlan 1
ip address 192.168.1.11 255.255.255.0

Inter-switch Connectivity Configuration Requirements:

– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans. This mode should be done with a non-proprietary protocol, with SwitchA controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
Note: Two above commands must be deleted first to form a trunking link.

Although the first requirement asks us to configure trunking but we can ignore this task because we only need to configure trunking under their Port-channel (in the next task)

– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all Vlans:
SW-A(config)#interface range fa0/3 – 4
SW-A(config-if)#no switchport mode access
SW-A(config-if)#no switchport access vlan 98
SW-A(config-if)#switchport trunk encapsulation dot1q
SW-A(config-if)#channel-group 1 mode active
SW-A(config-if)#channel-protocol lacp
SW-A(config-if)#no shutdown
– Trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link:
SW-A(config-if)#switchport mode trunk //unconditional trunking
SW-A(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches and make other VLANs to be tagged
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.
SW-A(config-if)#switchport trunk allowed vlan 1,21-23
—————————————
SW-B(config)#interface range Fa0/3 – 4
SW-B(config-if)#switchport trunk encapsulation dot1q
SW-B(config-if)#switchport mode trunk
SW-B(config-if)#switchport trunk native vlan 99 //this command will prevent the “Native VLAN mismatched” error on both switches
SW-B(config-if)#switchport trunk allowed vlan 1,21-23
SW-B(config-if)#channel-group 1 mode passive
SW-B(config-if)#channel-protocol lacp
SW-B(config-if)#no shutdown

Some notes for this sim:
+ You should check the initial status of both switches with these commands: show vtp status (transparent mode on SwitchA and we have to set the same mode on SwitchB), show spanning-tree [summary] (rapid-pvst mode on SwitchA and we have to set the same mode on SwitchB), show vlan (check the native vlan and the existence of vlan99), show etherchannel 1 port-channel and show ip int brief (check if Port-channel 1 has been created and make sure it is up), show run (to check everything again).
+ When using “int range f0/x – y” command hit space bar before and after “-” otherwise the simulator does not accept it.
+ You must create VLAN 99 for the SwitchB. SwitchA already has VLAN 99 configured.
+ At the end, you can try to ping from SwitchB to RouterA (you can get the IP on RouterA via the show cdp neighbors detail on SwitchA), not sure if it can ping or not. If not, you can use the “ip default-gateway 192.168.1.1” on SwitchB.
+ The name of SwitchA and SwitchB can be swapped or changed so be careful to put your configuration into appropriate switch.

The following “show” commands should be used to verify the configuration:

+ show vlan (check if the VLANs and VLAN names are correct)
+ show interface trunk (check if physical and port-channel is in trunking mode; the native VLANs on two switches match; allowed VLANs are correct)
+ show etherchannel summary (check Etherchannel status and LACP mode)
+ show ip interface brief (make sure the configured ports are up/up)
+ show spanning-tree (check STP mode)
+ show spanning-tree detail (can be used to check PortFast on specific interface but not sure if this command is supported in the exam)
+ show vtp status
+ show run (verify everything again)

Other lab-sims in this site:

MLS and EIGRP Sim
VTP Lab 2
VTP Lab
Spanning Tree Lab Sim
AAAdot1x Lab Sim

Comments
Comment pages
1 67 68 69 70 71 52
  1. Dmytro
    September 11th, 2019

    Henry, congrats!
    Tel me please, you configured STP priority for vlans 11-13 and 21-23 on SwitchA?

  2. Ampao
    September 12th, 2019

    Anyone please help.. I have tried configuring this in packetracer and had the ethchannel configured on fa0/3-4 just like in this lab. But the native vlan is keeps on notifyinv so i had to go to Po1 interface to match native vlan. Is it necessary in the exam to match native vlan at Interface Po1?

  3. Doja
    September 12th, 2019

    lets GET ITTTTTTT. Could you please help me with the latest dumps? I need it badly, please.

  4. Ampao
    September 13th, 2019

    For lacp+stp sim (config on physical interface only) , do we still have to configure this at Po1 on actual exam or not?
    #
    interface port-channel1
    switchport mode trunk
    switchport trunk native vlan 99
    switchport trunk allowed vlan 1,21-23,99
    no shut

  5. HelloMe
    September 13th, 2019

    I passed the exam yesterday with an 867 score but got graded in three areas only. New questions about 10 of them. My advice is to spend time thinking about your answer by eliminating obviously incorrect answers keeping in mind remaining time/questions to answer. I got 44 questions, one lab sim, and a testlet.

  6. Whatis
    September 13th, 2019

    @Ampao,

    I did not define native vlan on the po1 interface, only on the two trunk ethernet interfaces of both switches. Once I did this, the message stopped appearing.

    ———–
    Anyone please help.. I have tried configuring this in packetracer and had the ethchannel configured on fa0/3-4 just like in this lab. But the native vlan is keeps on notifyinv so i had to go to Po1 interface to match native vlan. Is it necessary in the exam to match native vlan at Interface Po1?

  7. Anonymous
    September 14th, 2019

    Hi HelloMe, please help me by sharing your dump, my email is bluemooncanada2019 at gmail . com thanks.

  8. Ampao
    September 14th, 2019

    Thank you @Whatis! Any reworded/modified instruction seen on the lab?

  9. FreqFeeder
    September 14th, 2019

    Hey Guys,
    Practicing this lab, I couldn’t understand where to find that the native VLAN is 99 – With the configuring instructions here, it just imply by the name TrunkNative, but nothing else is being configured – there are no trunks pre-configured with a ‘switchport trunk native vlan 99’
    So just to understand the logic – from the question it is clear that VLAN 1 should not be the native VLAN, so does it mean any other VLAN that is not in use could be the native VLAN?
    How can I found a native VLAN in this scenario?
    The only reason I could think of that there is a mismatch is because interfaces f0/3-4 on Switch A use VLAN 98 as ACCESS PORTS, and on Switch B these ports use the default VLAN 1 before configuration – but Access VLAN is NOT a native VLAN, and again, there is no place in the question or on the topology that mentions VLAN 99 is configured as native on Switch A.
    I’d appreciate if someone can clarify :)

  10. BlueMoon
    September 15th, 2019

    Can anyone please share the dump with me. Thanks.
    bluemooncanada2019 @ gmail

  11. Anonymous
    September 15th, 2019

    Can anyone please share the lab config file with me. Thanks.
    bluemooncanada2019 @ gmail

  12. Anonymous
    September 15th, 2019
  13. Anonymous
    September 15th, 2019

    this question repeated in 10/9/2019

  14. Lets Get ITTTTTTl
    September 15th, 2019

    Yo doja write me your email here

  15. Lets Get ITTTTTT
    September 15th, 2019

    FreqFeeder, when I attempted my exam, I had to show run first bcoz sometimes there is native vlan 98.

  16. Kami
    September 15th, 2019

    Can someone please send me the latest dumps. would really really appreciate it. Thanks.
    My email is scorpionkami786 @ gmail

  17. Jaouad
    September 16th, 2019

    @Ampao

    Sure the Physicals interfaces and Po1 should have similar configuration

  18. BlueMoon
    September 16th, 2019

    Hey, lets GET ITTTTTTT. Could you please help me with the latest dumps? Thanks bluemooncanada2019 @ Gmail

  19. Anonymous
    September 17th, 2019

    Can someone please share the latest dumps? Email is johnny.be.good @ outlook.
    Thank you.

  20. BlueMoon
    September 17th, 2019

    None cares here to help others, some people are trying to sell their stuff. Too bad…

  21. Anonymous
    September 18th, 2019

    What is the Benefit of Premium Membership here?

  22. Sarah
    September 21st, 2019

    Any nice people can send me the switch valid dumps to (paynesarah768 @ gmail.com)
    with no spaces

  23. Anonymous
    September 22nd, 2019

    Can some pls send me the real valid dumps to {email not allowed}? Thks in advance!

  24. Anonymous
    September 22nd, 2019

    Can some pls send me the real valid dumps to tbccnp @ yahoo? Thks in advance!

  25. @FreqFeeder
    September 23rd, 2019

    It’s simply because switch A is already configured with VLAN 99 named as TrunkNative, so you’re being told by Cisco to use that as the Native VLAN over the trunk.

  26. Dmytro
    September 24th, 2019

    I have a question about this lab:
    1) – No routing is to be configured on SwitchB.
    Is that mean that we should remove “ip default-gateway 192.168.1.1” from SwitchB?

  27. Dmytro
    September 26th, 2019

    The ip default-gateway address does not mean that the switch is routing, the default gateway is normally used for remote management (I.E. the ability to telnet or ssh to the switch).

    To verify if ip routing is enabled, you could use the “show ip route” command, if you see “ICMP redirect cache is empty” then there is a good chance the switch is setup for L2.

  28. Dmytro
    September 26th, 2019

    I understand! Thanks for explaining.

  29. 007
    September 27th, 2019

    i was thinking Etherchannel configuration is wrong which posted here. i have donw all configuration on switch interfaces (fa0/3-4) then after completing all configuration when i verify my configuration, i found the Native Vlan is still not working!
    i executed command “show interface trunk” and found the Po1 is the only trunk interface on the switch and it’s working with native vlan 1…!!!

    well, i really trust the certprepare/digitaltut team so i decided to test it on GNS3 and you know what..!! it worked fine for me! that was damn PACKET TRACER BUG..!!!

    Thanks Certprepare/digitaltut for all your support in this regards..

    Regards
    007

  30. @Navarro
    September 27th, 2019

    Which OPTION is correct for this lab?

    OPTION A
    #switchport trunk allowed vlan 1,21-23,99
    #switchport trunk native vlan 99

    OPTION B
    #switchport trunk allowed vlan 1,21-23
    #switchport trunk native vlan 99

    I’m praticing with OPTION B as mentioned in CertPrepare but i’m seeing recently many people talking that the OPTION A is correct. I’m very confusing with this question in LAB.

    Someone can help me with this doubt? Thank you.

  31. Efiko
    September 28th, 2019

    @Navarro. Option B has got to be the way to do it. If you think about it, when native vlan is using its default value of 1, you are not required to include vlan-id 1 in the allowed list.

  32. Navarro
    September 30th, 2019

    @Efiko,

    Thank you so much! I have my exame in 2 weeks and i’m practicing this lab for more than 2 months, every day.

  33. ICE
    October 1st, 2019

    I need clarity on the Ether-channel configuration. Don’t we need to shutdown the it first before we enter all the configurations commands and once done run the NO shut command

  34. C
    October 1st, 2019

    @ICE

    Shut the interfaces before you configure the trunk then enable them that will avoid all the logging errors which you may receive until you configure the trunks correctly.

    However remembered to enable them and check the status. (At least that what I did)

  35. Kumar
    October 1st, 2019

    I have seen a GREAT example about LACP here
    https://ipcisco.com/lesson/link-aggregation-control-protocol/

  36. ICE
    October 2nd, 2019

    @ C

    Thank you very much for the clarification

  37. Anonymous
    October 3rd, 2019

    can any one share ccnp switching dumps please.
    imtiyazghare @ gmail.com

    wihtout space email id.
    if anyone interested contact me,We can group & study.
    whatsup no-0097450228416

  38. Moza
    October 5th, 2019

    @ Tet

    No i did not configure Interface port-channel1, yes on the packet tracer you need it but in the sim it works

    All commands were done on the interface itself, dot 1q needs to be enabled on switch B then mode trunk.

    I didn’t test all i made sure was the ether-channel was operational.

  39. Tet
    October 5th, 2019

    @ Moza

    Thank´s for Answer.
    maybe i come back to you for another Question

  40. Dean
    October 7th, 2019

    share the CCNP switch dumps abdul rehman abr 0343 @ gmail dot com

  41. Frankie
    October 9th, 2019

    For the manual pruning of the VLANs. Both switches have VLANs 11-13 configured so you would not allow only VLANs 1, 21-23 across the trunk. The only difference in VLAN configuration is VLAN 98 on Switch A. The command should be switchport trunk allowed vlan except 98.

  42. Frankie
    October 10th, 2019

    Last post was incorrect. I remembered the switches are running in VTP Transparent mode.

  43. g3n3r4l
    October 10th, 2019

    Hello guys, yesterday I did my CCNP 300-115 (switch), and passed!! Thanks, CerPrep!!!

    I had 44 questions, and my question number 42 was the LACP_STP lab. The same here! I did the configs but forgot to put the fa0/3-4 interfaces up, and this gave me some troubles, so don’t forget to put the fa0/3-4 interfaces to UP!!!

  44. JM
    October 11th, 2019

    no ip routing could not be executed in my lab. I think SwitchB already had routing disable. However, ip default-gateway 192.168.1.1 was not in the configuration. I added that to the configuration.

  45. Dmytro
    October 11th, 2019

    @g3n3r4l congratulations!
    Do you remember other labs from exam? I heard that there are three labs/activities in exam/

  46. Abdullah
    October 11th, 2019

    Hi all,
    Passed yesterday. All the questions here are valid. I had a couple of new questions.
    I remember one is something like ” you checked udld and found the interface status is ‘Unknown’
    What that mean?
    1 it will go to err disable.
    2 it is normal functional.
    3 it will go to err disable after 5 seconds.
    4 I don’t remember.
    I think the answer is 2.
    Other questions is something like ” udld aggressive mode found unidirectional link case
    What will happen?
    1 it will go immediately to error disable.
    2 it will wait configured time then it will be error disable.
    3 I don’t remember
    4 I don’t remember
    I don’t know the answer where as I know tge udld aggressive should make 8 tries then it goes to error disable.

    One question ” what the radius encrypt?
    1 password only
    2 name and password
    3 header
    4 all the packet
    The answer is 1.
    My test was 44 questions. Lacp stp, vtp3 and hsrp sim. No d&d
    Thanks certprepair. Thanks all friends here that shared help.
    No worries it is so easy. Good luck all.

  47. Tet
    October 13th, 2019

    Hello, i did this lab with packtracer.
    When i configured the Etherchannel and than the Portchannel1 , i do a “show etherchannel
    summary” on both switches the result:
    Sw_A#sh etherchannel summary
    Flags: D – down P – in port-channel
    I – stand-alone s – suspended
    H – Hot-standby (LACP only)
    R – Layer3 S – Layer2
    U – in use f – failed to allocate aggregator
    u – unsuitable for bundling
    w – waiting to be aggregated
    d – default port

    Number of channel-groups in use: 1
    Number of aggregators: 1

    Group Port-channel Protocol Ports
    ——+————-+———–+———————————————-

    1 Po1(SU) LACP Fa0/3(I) Fa0/4(I)
    Sw_A#

    Should the ports not be in (P) instead of (I) standalone ??

  48. nick
    October 13th, 2019

    hello guys, for those you have already given the exams, was the port-channel 1 already pre-configured on the switches or you configured it manually ? thanks in advance

  49. abdullah
    October 13th, 2019

    @nick
    No you have to conf it on both of the sws. but “Tab to complete” is supported so you can conf it like this “channel-g 1 m a” “channel-p m l”.
    becarful that you need to leave space before and aftere “-” in the “interface range” command only. like this ” interface range fa 0/3 – 4″
    goodluck.

  50. nick
    October 13th, 2019

    @abdullah

    thank you very much

Comment pages
1 67 68 69 70 71 52
  1. No trackbacks yet.