Home > EtherChannel Questions

EtherChannel Questions

May 8th, 2014 Go to comments

Here you will find answers to EtherChannel Questions

Notes:

The Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol (LACP) facilitate the automatic creation of EtherChannels by exchanging packets between Ethernet interfaces. The Port Aggregation Protocol (PAgP) is a Cisco-proprietary solution, and the Link Aggregation Control Protocol (LACP) is standards based.

LACP modes:

+ on: the link aggregation is forced to be formed without any LACP negotiation. A port-channel is formed only if the peer port is also in “on” mode.
+ off: disable LACP and prevent ports to form a port-channel
+ passive: the switch does not initiate the channel, but does understand incoming LACP packets
+ active: send LACP packets and willing to form a port-channel

PAgP modes:

+ on: The link aggregation is forced to be formed without any PAgP negotiation. A port-channel is formed only if the peer port is also in “on” mode.
+ off: disable PAgP and prevent ports to form a port-channel
+ desirable: send PAgP packets and willing to form a port-channel
+ auto: does not start PAgP packet negotiation but responds to PAgP packets it receives

An EtherChannel in Cisco can be defined as a Layer 2 EtherChannel or a Layer 3 EtherChannel.
+ For Layer 2 EtherChannel, physical ports are placed into an EtherChannel group. A logical port-channel interface will be created automatically. An example of configuring Layer 2 EtherChannel can be found in Question 1 in this article.

+ For Layer 3 EtherChannel, a Layer 3 Switch Virtual Interface (SVI) is created and then the physical ports are bound into this Layer 3 SVI. An example of configuring Layer 3 EtherChannel can be found in Question 6 in this article.

Question 1

Refer to the exhibit. LACP has been configured on Switch1 as shown. Which is the correct command set to configure LACP on Switch2?

LACP_channel-group.jpg

A.
Switch2# configure terminal
Switch2(config)# interface range gigabitethernet3/1 -2
Switch2(config-if)# channel-group 5 mode auto

B.
Switch2# configure terminal
Switch2(config)# interface range gigabitethemet3/1 -2
Switch2(config-if)# channel-group 5 mode passive

C.
Switch2# configure terminal
Switch2(config)# interface range gigabitethernet3/1 -2
Switch2(config-if)# channel-group 5 mode desirable

D.
Switch2# configure terminal
Switch2(config)# interface range gigabitethernet3/1 -2
Switch2(config-if)# channel-group 5 mode on

 

Answer: B

Explanation

LACP trunking supports four modes of operation, as follows:
* On: The link aggregation is forced to be formed without any LACP negotiation. In other words, the switch will neither send the LACP packet nor process any incoming LACP packet. This is similar to the on state for PAgP.
* Off: The link aggregation will not be formed. We do not send or understand the LACP packet. This is similar to the off state for PAgP.
* Passive: The switch does not initiate the channel, but does understand incoming LACP packets. The peer (in active state) initiates negotiation (by sending out an LACP packet) which we receive and reply to, eventually forming the aggregation channel with the peer. This is similar to the auto mode in PAgP.
* Active: We are willing to form an aggregate link, and initiate the negotiation. The link aggregate will be formed if the other end is running in LACP active or passive mode. This is similar to the desirable mode of PAgP.

LACP does not have “auto” & “desirable” modes so A & C are not correct.

Also there are only three valid combinations to run the LACP link aggregate, as follows:

Switch Switch Description
active active Recommended
active passive Link aggregation occurs if negotiation is successful.
on on Link aggregation occurs without LACP. Although this works, it is not recommended.

Therefore if Switch1 is set “active” mode, we cannot set “on” mode on Switch2 -> D is not correct.

Only answer B is suitable in this case.

(Reference: http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094470.shtml)

An example of configuring Layer 2 EtherChannel using LACP (applied these commands to both switches):

SW(config)#interface range f0/1 – 2
SW(config-if-range)#channel-group 1 mode active

Question 2

Refer to the exhibit. The command switchport mode access is issued on interface FastEthernet0/13 on switch CAT1. What will be the result?

channel-group_switchport-mode-access.jpg

A. The command will be rejected by the switch.
B. Interfaces FastEthernet0/13 and FastEthemet0/14 will no longer be bundled.
C. Dynamic Trunking Protocol will be turned off on interfaces FastEthernet0/13 and FastEthemet0/14.
D. Interfaces FastEthernet0/13 and FastEthernet0/14 will only allow traffic from the native VLAN.
E. Interfaces FastEthernet0/13 and FastEthernet0/14 will continue to pass traffic for VLANs 88,100,360.

 

Answer: B

Explanation

The default channel protocol in Cisco switches is Port Aggregation Protocol (PAgP). PAgP groups the interfaces with the same speed, duplex mode, native VLAN, VLAN range, and trunking status and type. After grouping the links into an EtherChannel, PAgP adds the group to the spanning tree as a single switch port.

An interface in the on mode that is added to a port channel is forced to have the same characteristics as the already existing on mode interfaces in the channel (applied for both PAgP & LACP). So if we configure “switchport mode access” on Fa0/13, this interface will no longer be bundled with Fa0/14.

(Reference: http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_14_ea1/configuration/guide/swethchl.html#wpxref12539)

Question 3

What is the result of entering the command “port-channel load-balance src-dst-ip” on an EtherChannel link?

A. Packets are distributed across the ports in the channel based on both the source and destination MAC addresses.
B. Packets are distributed across the ports in the channel based on both the source and destination IP addresses.
C. Packets are balanced across the ports in the channel based first on the source MAC address, then on the destination MAC address, then on the IP address.
D. Packets are distributed across the access ports in the channel based first on the source IP address and then the destination IP addresses.

 

Answer: B

Explanation

The syntax of configuring load balancing on a Cisco switch is:

Switch(config)# port-channel load-balance method

Many methods can be used here. By default, the “src-dst-ip” (source and destination IP address) method is used for Layer 3 switching. Let’s take an example to understand more about this method.

EtherChannel_Load_balancing-src-dst-ip.jpg

In the topology above, Switch1 uses the “src-dst-ip” method to load balancing traffic to Switch2. With this method, only one link is used for a specific pair of source & destination IP address and the switch uses the XOR function to generate the hash that is used to determine which interface to use. Suppose the packets have the source IP of 1.1.1.1 & destination IP of 1.1.1.2. Write them in binary we get:

1.1.1.1 = 0000 0001.0000 0001.0000 0001.0000 0001
1.1.1.2 = 0000 0001.0000 0001.0000 0001.0000 0010

In this case we have only 2 interfaces in this channel group so the XOR function only gets the last bit, which means 1 XOR 0 = 1. Each interface is assigned an index that starts from 0 so Fa0/2 will be indexed 1 -> traffic will be sent over Fa0/2.

If we have 4 interfaces in a channel group then XOR function gets last 2 bits. If we have 8 interfaces, it gets 3 bits and so on. For example, with 8 interfaces the result will be 3 (because 001 XOR 010 = 011) -> Fa0/4 will be used.

Note: If the two address values have the same bit value, the XOR result is always 0. If the two address bits differ, the XOR result is always 1. For example, 0 XOR 0 = 0; 0 XOR 1 = 1; 1 XOR 0 = 1; 1 XOR 1 = 0.

In conclusion, the “port-channel load-balance src-dst-ip” command uses a pair of source & destination IP address to select the port to send traffic to -> B is correct.

Question 4

Refer to the exhibit. Which statement is true about the display of the command “show pagp 1 neighbor” command?

show_pagp_neighbor.jpg

A. STP packets are sent out the Gi0/1 interface only.
B. STP packets are sent out both the Gi0/1 and Gi0/2 interfaces.
C. CDP packets are sent out the Gi0/1 interface only.
D. CDP packets are sent out the Gi0/2 interface only.

 

Answer: A

Explanation

DTP and CDP send and receive packets over all the physical interfaces in the EtherChannel while STP always chooses the first operational port in an EtherChannel bundle -> A is correct.

Question 5

Refer to the exhibit. On the basis of the information that is generated by the show commands, which two EtherChannel statements are true? (Choose two)

show_etherchannel_summary.jpg

A. Interfaces FastEthernet 0/1 and 0/2 have been configured with the channel-group 1 mode desirable command.
B. Interfaces FastEthernet 0/3 and 0/4 have been configured with the no switchport command.
C. Interface Port-Channels 1 and 2 have been assigned IP addresses with the ip address commands.
D. Port-Channels 1 and 2 are providing two 400 Mbps EtherChannels.
E. Port-Channels 1 and 2 are capable of combining up to 8 FastEthernet ports to provide full-duplex bandwidth of up to 16 Gbps between a switch and another switch or host.
F. Switch SW1 has been configured with a Layer 3 EtherChannel.

 

Answer: A D

Explanation

In fact answer A is not totally correct because two ports Fa0/1 & Fa0/2 of Sw1 can use the “channel-group 1 mode auto” command while the peer ports use the “channel-group 1 mode desirable” command. But maybe it is the best choice in this case.

Answer B is not correct because this is a Layer 2 EtherChannel (from the lines “Po1 (SU)” & “Group state = L2”) but the “no switchport” is only used to configure Layer 3 EtherChannel.

Answer C is not correct because the port-channel is automatically created in a Layer 2 EtherChannel.

In this case we can see the ports are FastEthernet ports -> Port-Channels 1 and 2 are capable of combining up to 8 FastEthernet ports to provide full-duplex bandwidth of up to 1.6 Gbps (8 links of FastEthernet ports), not 16 Gbps. Port-Channels can provide up to 16 Gbps if they group 8 links of GigabitEthernet -> E is not correct.

SW1 has been configured with a Layer 2 EtherChannel (from the lines “Po1 (SU)” & “Group state = L2”) -> F is not correct.

Usually the EtherChannel protocol is shown when using the “show etherchannel summary” command (after the “Port-channel” column) but in this case we see no “protocol” column so we can assume it uses the default EtherChannel protocol PAgP.

There are 2 ports in each group so there are 4 Ethernet ports in total -> 4 x 100Mbps = 400Mbps in full duplex (which means “two 400 Mbps EtherChannels” in answer D) -> D is correct.

Question 6

Which statement is true regarding the Port Aggregation Protocol?

A. Configuration changes made on the port-channel interface apply to all physical ports assigned to the portchannel interface.
B. Configuration changes made on a physical port that is a member of a port-channel interface apply to the port-channel interface.
C. Configuration changes are not permitted with Port Aggregation Protocol; instead, the standardized Link Aggregation Control Protocol should be used if configuration changes are required.
D. The physical port must first be disassociated from the port-channel interface before any configuration changes can be made.

 

Answer: A

Explanation

The port-channel interface represents for the whole bundle and all the configurations on this interface are applied to all physical ports that are assigned to this logical interface.

Note: We must manually create port-channel logical interface when configuring Layer 3 EtherChannels. The port-channel logical interface is automatically created when configuring Layer 2 EtherChannels (you can’t put Layer 2 ports into a manually created port channel interface).

An example of configuring Layer 3 EtherChannels with port-channel interfaces:

EtherChannel_Load_balancing-src-dst-ip.jpg

Switch1(config)# interface port-channel 1
Switch1(config-if)# no switchport
Switch1(config-if)# ip address 192.168.1.1 255.255.255.0
Switch1(config-if)# exit
Switch1(config)# interface range fastethernet0/1 -2
Switch1(config-if-range)# no switchport
Switch1(config-if-range)# no ip address
Switch1(config-if-range)# channel-group 1 mode desirable
Switch2(config)# interface port-channel 1
Switch2(config-if)# no switchport
Switch2(config-if)# ip address 192.168.1.2 255.255.255.0
Switch2(config-if)# exit
Switch2(config)# interface range fastethernet0/1 -2
Switch2(config-if-range)# no switchport
Switch2(config-if-range)# no ip address
Switch2(config-if-range)# channel-group 1 mode auto

Note: The “no switchport” command is required to change interface from layer2 to layer3 mode.

Question 7

Which three statements are true of the Link Aggregation Control Protocol (LACP)? (Choose three)

A. LACP is used to connect to non-Cisco devices.
B. LACP packets are sent with the command channel-group 1 mode desirable.
C. LACP packets are sent with the command channel-group 1 mode active.
D. Standby interfaces should be configured with a higher priority.
E. Standby interfaces should be configured with a lower priority.

 

Answer: A C D

Explanation

LACP is part of the IEEE specification 802.3ad so that it can be used on non-Cisco devices -> A is correct.

With mode “active”, the switch will send LACP packets, initiates negotiations with remote ports and willing to form a port-channel if it receives a response -> C is correct.

LACP uses the port priority with the port number to form the port identifier. The port priority determines which ports should be put in standby mode when there is a hardware limitation that prevents all compatible ports from aggregating.

An example of configuring LACP port priority:

Router(config-if)# lacp port-priority 100

Note: Valid range is from 1 to 65535. The higher the number, the lower the priority so standby interfaces should be configured with a higher priority -> D is correct.

Question 8

Refer to the exhibit. What does the command channel-group 1 mode desirable do?

Interface FastEthernet 0/13
Channel-group 1 mode desirable

A. enables LACP unconditionally
B. enables PAgP only if a PAgP device is detected
C. enables PAgP unconditionally
D. enables Etherchannel only
E. enables LACP only if a LACP device is detected

 

Answer: C

Explanation

First, “desirable” is a mode on PAgP, not LACP. “enable PAgP unconditionally” means that port will send PAgP packets to form an EtherChannel port (initiate negotiations with other ports). A channel is formed with another port group in either desirable or auto mode.

Note:

Mode “auto” enables PAgP only if a PAgP device is detected and mode “on” forces the port to form a channel.

Question 9

Which statement best describes implementing a Layer 3 EtherChannel?

A. EtherChannel is a Layer 2 and not a Layer 3 feature.
B. Implementation requires switchport mode trunk and matching parameters between switches.
C. Implementation requires disabling switchport mode.
D. A Layer 3 address is assigned to the channel-group interface.

 

Answer: C

Explanation

By default, the ports on a multilayer switch (MLS) will all be running in Layer 2 mode. A port must be configured as a routing port before it is configured as a Layer 3 EtherChannel -> require to use the “no switchport” command.

Comments
  1. No comments yet.
  1. No trackbacks yet.